We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

ggc autocomplete cells value should not change on double click/ single click

Thread ID:

Created:

Updated:

Platform:

Replies:

70227 Dec 3,2007 08:47 AM Dec 3,2007 12:10 PM Windows Forms 1
loading
Tags: GridControl
abc
Asked On December 3, 2007 08:47 AM

I am using syncfusion ggc 5.2. For implementing AutoComplete in one column i have used following code.

this.ggcMapDetails.TableDescriptor.Columns["AssetName"].Appearance.AnyRecordFieldCell.CellType = "ComboBox";
this.ggcMapDetails.TableDescriptor.Columns["AssetName"].Appearance.AnyRecordFieldCell.ChoiceList = null;
this.ggcMapDetails.TableDescriptor.Columns["AssetName"].Appearance.AnyRecordFieldCell.DropDownStyle = GridDropDownStyle.Editable;
this.ggcMapDetails.TableDescriptor.Columns["AssetName"].Appearance.AnyRecordFieldCell.ShowButtons = GridShowButtons.Hide;

Now when i click/double click on any cell of AutoComplete it the values start changing on my previous added values.
I want that AutoComplete columns values should only change when i write something in that cell not that when i click on that cell.

I will be v helpful if anyone could help me in this.



haneefm [Syncfusion]
Replied On December 3, 2007 12:10 PM

Hi Prabhjeet,

You turn off selecting the next index when user double clicks inside the cell by setting the AllowDoubleClickChangeSelectedIndex property to false. Here is a code snippet

//Access the cellModel
GridComboBoxCellModel cm = this.grid.TableModel.CellModels["ComboBox"] as GridComboBoxCellModel;

//Lets you enable or turn off selecting the next index when user double clicks inside cell.
cm.AllowDoubleClickChangeSelectedIndex = false;

Best regards,
Haneef


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;