We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : Nov 16th 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Alpha channel of background colors inverted

Thread ID:

Created:

Updated:

Platform:

Replies:

69736 Nov 9,2007 04:45 PM UTC Dec 19,2007 06:24 AM UTC WinForms 2
loading
Tags: XlsIO
Christian Muirhead
Asked On November 9, 2007 04:45 PM UTC

When importing from Excel, we get background colors with incorrect alpha channels - a green cell has an alpha component of 0, where we would expect it to be 255. When a cell has no color set, its backcolor comes in as (255, 0, 0, 0) - fully opaque black.

Are we reading this wrong? Is there a reason for this behaviour?

Thanks,
Christian


Melba Winshia [Syncfusion]
Replied On November 10, 2007 01:19 PM UTC

Hi Christian,

Thank you for your interest in Syncfusion Products.

1)a green cell has an alpha component of 0, where we would expect it to be 255.

I am afraid that I was not able to reproduce the issue. The green cell has an alpha component as 255 and not 0. Also I have created a simple sample and it is available in the below link:

http://websamples.syncfusion.com/samples/XlsIO.Windows/69736_1/main.htm

Please have a look at the above sample and if still the issue exists, could you please try reproducing it in the above sample and send us the modified sample so that we could sort out the cause of the issue and provide you a solution?

2) When a cell has no color set, its backcolor comes in as (255, 0, 0, 0) - fully opaque black.

We suspect this issue to be a defect and we thank you for bringing this to our attention. To facilitate tracking the progress of the fix we request you to create an incident with the subject as "Alpha channel of background colors inverted - 69736" in our incident database Direct Trac.

Please let me know if you have any other questions.

Thanks,
Melba



Geetha M [Syncfusion]
Replied On December 19, 2007 06:24 AM UTC

Hi Christian,

The issue of Cell backcolor value is not returned correctly if NoFill is set has been confirmed as a defect and a defect report has been logged. You can track the status of this defect in the following link:

http://www.syncfusion.com/support/issues/xlsio/Default.aspx?ToDo=view&questId=7682

Please let me know if you have any concerns.

Regards,
Geetha


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;