We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Extra closing parenthis create a red wavy underline

Thread ID:

Created:

Updated:

Platform:

Replies:

69677 Nov 7,2007 05:35 PM UTC Nov 13,2007 12:59 PM UTC Windows Forms 5
loading
Tags: EditControl
E Beck
Asked On November 7, 2007 05:35 PM UTC

Whenever I type a ")" into the edit control, and it is an extra one (there is not a matching "(" occuring prior to it on the same line) a red wavy underline appears informing me of the "extraneous" clsoing parenthesis. I don't want it to do this, how do I turn this feature off?

Fathima Shalini P [Syncfusion]
Replied On November 9, 2007 11:49 AM UTC

Hi Beck,

Thanks for your interest in Syncfusion Products.

I have tried using ) in Edit Control of 5.2.0.25 built. But I couldnt find any error lines displayed in it.

Please do find the video file in the following link.

http://www.syncfusion.com/Support/user/uploads/MySample_5e07cec4.zip

Please send me a sample and reproducing steps so that I could provide you a solution.

Please let me know if any queries regarding.

Regards,
Fathima Shalini.P


E Beck
Replied On November 9, 2007 03:50 PM UTC

We are using version 4.102.0.50


Fathima Shalini P [Syncfusion]
Replied On November 12, 2007 07:41 AM UTC

Hi Beck,

I have tried using ) in the Edit Control using V4.1.0.50 build. I couldnt see any error lines in it. Please do find the video file in the following link for more reference.

http://www.syncfusion.com/Support/user/uploads/VideoSample_e6013810.zip

Please send me a sample or a video so that I could provide you a better solution.

Please let me know if any queries regarding.

Regards,
Fathima Shalini.P


E Beck
Replied On November 12, 2007 05:42 PM UTC

Within it we are loading up the default available C# syntax setting. You can replicate the a basic windows C# applicaiton with just the edit control on the form and the following source code in the Form1.cs file. Added reference DLLs are Syncfusion.Core, syncfusion.Edit.Windows, Syncfusion.Shared.Base

[code]
using System;
using System.Collections.Generic;
using System.ComponentModel;
using System.Data;
using System.Drawing;
using System.Text;
using System.Windows.Forms;

namespace WindowsApplication4
{
public partial class Form1 : Form
{
public Form1()
{
InitializeComponent();
}

private void Form1_Load(object sender, EventArgs e)
{
editControl1.NewFile(editControl1.Configurator["C#"]);
}
}
}[/code]


Fathima Shalini P [Syncfusion]
Replied On November 13, 2007 12:59 PM UTC

Hi Beck,

Thanks for this detailed information. It is possible to turn off displaying error lines when using ) alone, while using C# configuration in Edit control by removing the Type="Error" property in the config.xml.

Please refer the code snippets and sample below for the correct behaviour.
[Config.xml]



IsCollapsable="false" CollapseName="(...)">






http://websamples.syncfusion.com/samples/Edit/F69677/main.htm

Please try this and let me know if this helps.

Regards,
Fathima



CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;