We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

I do not manage to unhide column

Thread ID:

Created:

Updated:

Platform:

Replies:

69522 Oct 31,2007 07:10 AM Nov 24,2007 01:03 AM Windows Forms 3
loading
Tags: GridControl
ToDo
Asked On October 31, 2007 07:10 AM

Hi,
I would like to unhide the hidden columns during an internal operation but although I pass the line
grid.HideCols.Item(colIndex) = False
at debug the property
grid.HideCols.Item(colIndex) remains set to true.

I use version 5.102.0.51. I need to solve it in this version.

Thanks for your help!
Regards,
ToDo

Jeba S [Syncfusion]
Replied On October 31, 2007 09:04 AM

Hi ToDo,

Thank you for posting query to us.

I am afraid that I was not able to reproduce the hidden issue in the below sample.
http://websamples.syncfusion.com/samples/Grid.Windows/F69522/main.htm

Please have a look at the sample and if still the issue exists, could you please elaborate the reproduce steps so that we could sort out the cause of the issue and provide you a solution?

The logic for handling hidden columns has been changed in our code base to increase performance from version 4.4. A static property UseOldHiddenScrollLogic property has been added to the GridControlBase.

GridControl.UseOldHiddenScrollLogic = true;

Please try this and let us know if this helps.

Thank you for using Syncfusion Products.

Best Regards,
Jeba.


Sopen
Replied On November 22, 2007 09:13 AM

This seems to be a bug in the new version. I had the same problem with unhiding hidden columns as ToDo, using the same version (5.102.0.51).

Setting
GridControl.UseOldHiddenScrollLogic = True
fixed the problem.

Thanks,
Sopen




Jeba S [Syncfusion]
Replied On November 24, 2007 01:03 AM

Hi Sopen,

In 4.4.0.51, there was a redesign of the hidden columns support to try to improve the performance of the grid with large numbers of hidden rows and columns. So this is not a bug.

If you are hiding the columns using grid.Cols.Hidden[colIndex] = true ( or grid.SetColHidden or any other technique that ultimately relies on the setting Hidden property), then instead, try setting grid.ColWidths[colIndex] = 0 to hide the columns. Before doing so, you would have to cache the colwidths so you would be able to unhide them later. The goal is to not use the Cols.Hidden property to hide the columns (using the setting of the ColWidth = 0 instead).

Kindly let us know if you need any further assistance.

Best Regards,
Jeba.



CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;