We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Syncfusion 4.30.0.3 problem creating or validating license?

Thread ID:

Created:

Updated:

Platform:

Replies:

67395 Aug 16,2007 11:09 AM Aug 22,2007 12:21 AM General Discussion 4
loading
Tags: General Discussion
Robert Hancliff
Asked On August 16, 2007 11:09 AM

I have tried so many different things to correct this error which I have had for a couple of weeks and really do need to get sorted now.

First off when I run our app I get a dialog warning of a licensing error. View diagnostics shows the following.

Syncfusion Licensing System - Detailed diagnostics.

ErrorKind = RuntimeNoLicx

UsageMode = Runtime

IsAspDotNet = False

RuntimeLicenseKey = No runtime license key found in licx.

ExecutingVersionInfo = Syncfusion.Core, Version=4.3.0.30, Culture=neutral, PublicKeyToken=632609b4d040f6b4

ExecutingVersionInfoFromAssembly = Syncfusion.Core.Licensing.FusionLicenseProvider, Syncfusion.Core, Version=4.3.0.0, Culture=neutral, PublicKeyToken=632609b4d040f6b4

ErrorMessage =

No Assemblies with licenses.licx resource found.

No Syncfusion.Core entries found in licenses.licx files.


I click Fix it and generally it says changes were not made. I have followed all instructions it suggests to no success, however no certain configurations, usually checking everythign out I am told the license changes were made succesfully however the problem simply repeats and always just tells me all was ok.


I have re-installed syncfusion, obtained a new license key, deleted the assemvlies from gac, ran the licensing manager app.

I cannot for the life of me sort it out. I have deleted the local copy andgot again from our Source Control which other users have done and been 100% succesful, when I do it the error still occurs and I really do need to correct it. It's clearly a local problem. Any further guidance is more than appreciated.

Robert Hancliff
Replied On August 16, 2007 11:33 AM

Also it's worth noting in the IDE I get this message

licenses.licx Could not transform licenses file 'licenses.licx' into a binary resource. (1) : error LC0004 : Exception occured creating type 'System.Security.SecurityException'

Nandakumar R [Syncfusion]
Replied On August 17, 2007 03:12 PM



Hi Robert,

I regret for the delay in getting back to you.

I have re-installed syncfusion, obtained a new license key, deleted the assemvlies from gac, ran the licensing manager app.

Can you please check if the Syncfusion assemblies are installed in the PublicAssemblies folder and in the GAC?

got again from our Source Control which other users have done
Does this means the application source has been accessed from a network share?

In such a case, please add Full Trust to local Intranet settings. This can be done with the help of the below document.

http://www.syncfusion.com/support/user/uploads/SecuritySettings.pdf

Please try this and let me know if this helps. Thank you for your interest in Syncfusion products.

Regards,
Nanda

Robert Hancliff
Replied On August 20, 2007 08:00 AM

Hi, thanks for the reply, the assemblies are definitely in the public assemblies folder.

I also changed the permission via the every wizard I found in that panel and I still have the same problem. I am totally confused myself after trying so many different resolutions.

I do realise it's a local issue as well. I'm stumped, mine looks the same as everyone elses and we all use the same source control etc (obviously I know but I checked none the less).

Ramu [Syncfusion]
Replied On August 22, 2007 12:21 AM

Hi Robert,

Please follow the below steps to apply full trust to the assemblies and files in the .NET 2.0 Framework.


1) Please open the “Administrative Tools” from the control panel.

2) Double click “Microsoft .NET Framework 2.0 Configuration” in “Administrative Tools” to open the .NET 2.0 configuration.

3) Navigate to “All code” through the following path “My computer -> Runtime security -> Machine -> Code Groups in “Microsoft .NET Framework 2.0 Configuration”.

4) Right click “All code” and select properties in the menu. Its properties will be displayed.

5) In the permission set tab, set Full Trust in the combo box of the permission set.

6) Click the OK button.

I have attached the screen shot for more information.
http://www.syncfusion.com/Support/user/uploads/fulltrust_ea8e9148.zip

Please let me know if this solves your issue.

Thanks,
Ramu


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;