We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

disable cell editor for GridGroupingControl

Thread ID:

Created:

Updated:

Platform:

Replies:

66860 Aug 3,2007 09:55 AM Aug 6,2007 11:58 AM Windows Forms 2
loading
Tags: Grouping
yan
Asked On August 3, 2007 09:55 AM

Hi,

I am using GridGroupingControl to display data in my project. I want my data to be read only. I have gone through each column to set ReadOnly to true as well as the TableModel

gridPrice.TableDescriptor.Columns[i].ReadOnly = true;
gridPrice.TableModel.ReadOnly = true;

They did become readonly. However the editors are still active. Ex. my Date cell still drop down the datatimepicker. Is there anyway to disable the cell editors? I don't want my grid to be disabled since I still want the rows to be selectable.

Thanks,
Jenny


haneefm [Syncfusion]
Replied On August 3, 2007 07:07 PM

Hi Jenny,

Try setting the Clickable property of the column to false in a grid and let me know if this helps.

gridPrice.TableDescriptor.Columns[i].Appearance.AnyRecordFieldCell.Clickable = false;

Best regards,
Haneef


yan
Replied On August 6, 2007 11:58 AM



>Hi Jenny,

Try setting the Clickable property of the column to false in a grid and let me know if this helps.

gridPrice.TableDescriptor.Columns[i].Appearance.AnyRecordFieldCell.Clickable = false;

Best regards,
Haneef



Hi Haneef,

Thanks for your help. I have tried to set the clickable to false. However it still does not work.

Jenny

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;