We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : Nov 16th 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

ClickOnce in 2007 (v5)

Thread ID:

Created:

Updated:

Platform:

Replies:

64894 Jul 24,2007 01:48 PM UTC Jul 30,2007 10:51 PM UTC General Discussion 6
loading
Tags: General Discussion
Jason MacEntee
Asked On July 24, 2007 01:48 PM UTC

There are several discussions and KB articles on ClickOnce, but they all pre-date version 5.

Is there a current "best practice" step-by-step for using ClickOnce with Syncfusion Windows Forms v5?

Thanks,
Jason

Daniel Jebaraj [Syncfusion]
Replied On July 25, 2007 08:59 PM UTC

Hi Jason,

You are correct. The information needed for this is in bits and pieces. We will consolidate and have an article available for you before Monday (7/30).

Thanks,
Daniel

>There are several discussions and KB articles on ClickOnce, but they all pre-date version 5.

Is there a current "best practice" step-by-step for using ClickOnce with Syncfusion Windows Forms v5?

Thanks,
Jason

Jason MacEntee
Replied On July 26, 2007 12:18 PM UTC

Thank you, Daniel, that would be great.

I have to demo my project for my client on Monday (7/30) and I really want to do it via ClickOnce if possible.

--Jason

>Hi Jason,

You are correct. The information needed for this is in bits and pieces. We will consolidate and have an article available for you before Monday (7/30).

Thanks,
Daniel

>There are several discussions and KB articles on ClickOnce, but they all pre-date version 5.

Is there a current "best practice" step-by-step for using ClickOnce with Syncfusion Windows Forms v5?

Thanks,
Jason

Daniel Jebaraj [Syncfusion]
Replied On July 30, 2007 11:02 AM UTC

Hi Jason,

We have prepared an article that details the steps involved with ClickOnce deployment when using the Syncfusion libraries. You can download this article from

http://www2.syncfusion.com/installs/articles/syncfusion_clickonce.zip
.

Please note that there is a tool called netdepends.exe that is referenced in this article. This tool is optional (for the purpose of deployment preparation) and is not available now. We will make it available before tomorrow.

The final version of this article will be published to our website in a few days. Please send us any feedback on the current draft.

Thank you for using Syncfusion products.

Best regards,
Daniel


>Thank you, Daniel, that would be great.

I have to demo my project for my client on Monday (7/30) and I really want to do it via ClickOnce if possible.

--Jason

>Hi Jason,

You are correct. The information needed for this is in bits and pieces. We will consolidate and have an article available for you before Monday (7/30).

Thanks,
Daniel

>There are several discussions and KB articles on ClickOnce, but they all pre-date version 5.

Is there a current "best practice" step-by-step for using ClickOnce with Syncfusion Windows Forms v5?

Thanks,
Jason

Jason MacEntee
Replied On July 30, 2007 04:02 PM UTC

Thank you for the information.
I am attempting to follow the instructions, but it is not working for me correctly.

If my "Application Files..." list of Syncfusion DLLS is set to Prerequisite (Auto) (or just Prerequisite), then the Download Group is set to (None) with no option to change it. Consquently, no DLLS are included in the publish folder.

On the other hand, if I change the Publish Status to "Include", then the DLLs are included int he publish folder, but when I go to install it on a fresh PC, I get the message that "Syncfusion.Sared.Windows Version 5.102.0.51 must be installing in the GAC, first"

Please advise.
Jason

Daniel Jebaraj [Syncfusion]
Replied On July 30, 2007 05:48 PM UTC

Hi Jason,

Sorry, we should have mentioned this in the document. I will update this in the document. The solution is to explicitly set the "Publish Status" for each of the Syncfusion assemblies to be "Include". I am surprised that this does not work. Can you increment the version number in the publish dialog and try again after setting status to "Include"? If this does not work, please email me at danielj syncfusion com and we can setup a time to work through this over the phone.

Sorry for the inconvenience.

Best regards,
Daniel

>Thank you for the information.
I am attempting to follow the instructions, but it is not working for me correctly.

If my "Application Files..." list of Syncfusion DLLS is set to Prerequisite (Auto) (or just Prerequisite), then the Download Group is set to (None) with no option to change it. Consquently, no DLLS are included in the publish folder.

On the other hand, if I change the Publish Status to "Include", then the DLLs are included int he publish folder, but when I go to install it on a fresh PC, I get the message that "Syncfusion.Sared.Windows Version 5.102.0.51 must be installing in the GAC, first"

Please advise.
Jason

Jason MacEntee
Replied On July 30, 2007 10:51 PM UTC

On second try, it did work. I had forgotten to set "Core" to "Include". When I got all of them set to include, it works fine.

Thanks!

Jason

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;