We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : Nov 16th 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Locking column headers on scroll

Thread ID:

Created:

Updated:

Platform:

Replies:

62357 Jun 13,2007 03:24 PM UTC Jun 21,2007 12:38 PM UTC WinForms 5
loading
Tags: Grouping
Paul Sullivan
Asked On June 13, 2007 03:24 PM UTC

Hi,
I'm trying to lock my column headers so that only the records scroll. Has anybody worked out how to do this in the Windows Grid Grouping control?

There is no equivalent to the GridGroupingControl.FrozenRows Property from the ASP.NET equivalent control.

Thanks
Paul

Rajagopal [Syncfusion]
Replied On June 13, 2007 06:16 PM UTC

Hi Paul,

When you have only the default column headers(row 0) you wont able to scroll the header row, but if you have more than one header rows, then you will be to scroll the header rows also. The GridGroupingControl currently has no support for freezing rows. There is no easy way to get this working at the moment. Sorry for the inconvenience.

Thanks,
Rajagopal

Paul Sullivan
Replied On June 20, 2007 02:20 PM UTC

Hi,
So, are you saying that if I only have the 1 (default) header row it will automatically freeze it? Maybe that will solve the problem, but I have an additional problem in that I get a "caption" telling me how many items are in the grid even though I think I have set all the caption properties to false.
The attached bmp shows my grid in run mode and the design time properties.
Can you tell me how to remove the "Table: 2 Items" caption?


GridProperties.zip

Rajagopal [Syncfusion]
Replied On June 20, 2007 06:19 PM UTC

Hi Paul,

I dont see this issue here in any of our samples. Setting the below properties will not allow you to show the caption row in the GridGroupingControl.

this.gridGroupingControl1.TopLevelGroupOptions.ShowCaption = false;
this.gridGroupingControl1.NestedTableGroupOptions.ShowCaption = false;
this.gridGroupingControl1.ChildGroupOptions.ShowCaption = false;

Please try the above property settings and let me know if this helps.

Regards,
Rajagopal

Paul Sullivan
Replied On June 21, 2007 10:27 AM UTC

Thanks Rajagopal, that looks to have fixed the problem!
Paul

Paul Sullivan
Replied On June 21, 2007 12:38 PM UTC

Sorry it removes the caption but does not freeze the first (header) row. Is it supposed to?

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;