We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Auto scroll

Thread ID:

Created:

Updated:

Platform:

Replies:

60898 May 14,2007 08:18 PM May 21,2007 09:06 AM Windows Forms 6
loading
Tags: Diagram
Julien GRAINGEOT
Asked On May 14, 2007 08:18 PM

In the V5, when I drag a shape outside the view area, it scroll automatically. How to disable this feature?

Thanks.

Meera Fathima [Syncfusion]
Replied On May 15, 2007 06:35 AM

Hi Graingeot,

Setting the Diagram.AutoScrolling = ScrollBars.None will let you disable the autoscroll property. But it seems this property is not working in v5.1 of Essential Diagram.

I will log a QA report on this issue and will try to fix this issue in the future release of the product.We apologize for the inconvenience caused.

Thanks and Regards,
Meera.

Satya Kolachina
Replied On May 16, 2007 10:32 AM

Hi Graingeot,

The autoscroll can be programmatically prevented by setting both the HScroll and VScroll properties of the diagram object to false, or whichever of them is desired to be disabled.

In the VS2005 form designer if you set these values, the control will not retain the values. This problem existed in 4.4 version as well as carried forward to 5.1. Syncfusion did not do anything to fix it in the new release (unfortunately).

However, programmatically this can be done as mentioned in the first paragraph. I did that way in 4.4, tested in 5.1 and found that it works in 5.1 also. However, I have not ported my appliaction to 5.1, since I do not normally port my appliation to newer version unless all the aspects relevant to my appliation are met in the 5.1 version. So, I do test the 5.1 with samples first and then finally port my application. That is my approach.

Regards,
Satya S Kolachina


>Hi Graingeot,

Setting the Diagram.AutoScrolling = ScrollBars.None will let you disable the autoscroll property. But it seems this property is not working in v5.1 of Essential Diagram.

I will log a QA report on this issue and will try to fix this issue in the future release of the product.We apologize for the inconvenience caused.

Thanks and Regards,
Meera.

Julien GRAINGEOT
Replied On May 16, 2007 01:28 PM

It does not work. I've wrote:

diagram.HScroll = false;
diagram.VScroll = false;
diagram.AutoScrolling = ScrollBars.None;

and diagram continue to scroll if I drag a shape near borders.

Julien GRAINGEOT
Replied On May 16, 2007 01:40 PM

My application must never scrolling, can I overdive some "scroll" function whith a "do nothing" function ? If this function exist, please tell me where is it.

Thanks.

Julien GRAINGEOT
Replied On May 17, 2007 05:33 PM

I thing the problem is not scroll. When I drag a shape near border, and see the View "scrolling", HorizontalScroll, VerticalScroll or WindowScrolling events are not fired. However, the "Origin" property is automaticaly modified.

How can I prevent this property to be changed?

Thanks.

Meera Fathima [Syncfusion]
Replied On May 21, 2007 09:06 AM


Hi Graingeot,

I am sorry about this delay in responding. Could you please open a new DT incident with the subject of this forum. So that you can follow-up with this issue statue through the incident.

Thanks you for using Essential Diagram.

Best Regards,
Meera.

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;