We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Wrap text is not working in Syncfusion.Window.Forms.Grid.Grouping.GridGropingControl

Thread ID:

Created:

Updated:

Platform:

Replies:

60658 May 9,2007 06:26 PM UTC May 10,2007 07:15 PM UTC WinForms 4
loading
Tags: GridControl
Ashok
Asked On May 9, 2007 06:26 PM UTC

Wrap text is not working in Syncfusion.Window.Forms.Grid.Grouping.GridGropingControl

only showing 4 character you can see field as 'Ctpy' in grid.

you can see code too, if you have code then pls attach me. i want filter and grouping, may be this can create problem

Wraptext0.zip

haneefm [Syncfusion]
Replied On May 9, 2007 08:38 PM UTC

Hi,

By default, the text in a cell wraps into a different line. You would have to probably make the cell taller to see the wrapped text. To change the rowheight of the column header, try setting the TableOptions.ColumnHeaderRowHeight property. Below is a code snippet.

this.gridGroupingControl1.TableOptions.ColumnHeaderRowHeight = 50;
this.gridGroupingControl1.TableOptions.RecordRowHeight = 70;

Also refer the below forum thread for more details.
http://www.syncfusion.com/Support/Forums/message.aspx?&MessageID=60033

Let me know if this is not what you needed.

Best regards,
Haneef

Ashok
Replied On May 10, 2007 12:44 AM UTC

Thanks Haneef

this code is useful for me, but my grid column filter not working

this.gridGroupingControl1.TableDescriptor.Columns[0].AllowFilter = true;

not showing filter column.


>Hi,

By default, the text in a cell wraps into a different line. You would have to probably make the cell taller to see the wrapped text. To change the rowheight of the column header, try setting the TableOptions.ColumnHeaderRowHeight property. Below is a code snippet.

this.gridGroupingControl1.TableOptions.ColumnHeaderRowHeight = 50;
this.gridGroupingControl1.TableOptions.RecordRowHeight = 70;

Also refer the below forum thread for more details.
http://www.syncfusion.com/Support/Forums/message.aspx?&MessageID=60033

Let me know if this is not what you needed.

Best regards,
Haneef

Ashok
Replied On May 10, 2007 09:42 AM UTC

Hi haneef,

this code is use full,

this.gridGroupingControl1.TableDescriptor.Columns[0].AllowFilter = true;

can you give me solution.


>Thanks Haneef

this code is useful for me, but my grid column filter not working

this.gridGroupingControl1.TableDescriptor.Columns[0].AllowFilter = true;

not showing filter column.


>Hi,

By default, the text in a cell wraps into a different line. You would have to probably make the cell taller to see the wrapped text. To change the rowheight of the column header, try setting the TableOptions.ColumnHeaderRowHeight property. Below is a code snippet.

this.gridGroupingControl1.TableOptions.ColumnHeaderRowHeight = 50;
this.gridGroupingControl1.TableOptions.RecordRowHeight = 70;

Also refer the below forum thread for more details.
http://www.syncfusion.com/Support/Forums/message.aspx?&MessageID=60033

Let me know if this is not what you needed.

Best regards,
Haneef

GGC_Forum_ResizeToFit_a41fcf800.zip

haneefm [Syncfusion]
Replied On May 10, 2007 07:15 PM UTC

Hi,

If you want to show the auto filter row in a grid then set the ShowFilterBar property to true.

//For TopLevelGroup
this.gridGroupingControl1.TopLevelGroupOptions.ShowFilterBar = true;
//For all nested level.
this.gridGroupingControl1.NestedTableGroupOptions.ShowFilterBar = true;
//For all child groups
this.gridGroupingControl1.ChildGroupOptions.ShowFilterBar = true;

Best regards,
Haneef

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;