We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Using Tabs

Thread ID:

Created:

Updated:

Platform:

Replies:

60404 May 4,2007 01:02 AM UTC May 4,2007 10:17 AM UTC WinForms 1
loading
Tags: DocIO
Rob Furley
Asked On May 4, 2007 01:02 AM UTC

Essential Studio 4.4.0.51, VS 2005 & Word 2002

If I use the following piece of code :

paragraph.paragraphformat.clear
paragraph.paragraphformat.tabs.addtab(100)
paragraph.appendtext("Demo" & vbtab & "AfterTab")

My word document does appear to contain the appropriate text (inc Tab symbol), however "AfterTab" is not lined up appropriately, and there does not appear to be any tab stops on the Ruler. If I manually (in Word) add a tab stop in the ruler - then everything looks OK.
I have tried many different values for the tabwidth, all with no luck.

What am I missing?

Bhuvaneswari P [Syncfusion]
Replied On May 4, 2007 10:17 AM UTC

Hi Rob,

Thanks a lot for your code snippet.

I was not able to reproduce the issue. The tab stops appear on the Ruler. I have created a sample using the above code snippet.

Herewith I have attached the sample for your reference:
http://websamples.syncfusion.com/samples/DocIO.Windows/F60404//main.htm

Herewith I have attached the generated word document:
Sample.doc

Please take a look into this and let me know if you have any other queries.

Thank you for your interest in Syncfusion products.

Best Regards,
Bhuvaneswari.


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;