We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

RowHeaders property affects keyboard navigation of GridControl

Thread ID:

Created:

Updated:

Platform:

Replies:

60224 Apr 30,2007 05:02 PM May 1,2007 02:59 PM Windows Forms 2
loading
Tags: GridControl
Julie Levy
Asked On April 30, 2007 05:02 PM

Hi -
I noticed that keyboard navigation sometimes doesn't work with our gridcontrol (tab keys and arrow keys). In the attached sample i have been able to narrow it down to the rowheader property. When it's true, i can navigate, when it's false i cannot. See Form1 in the sample. The property is set in InitializeGrid().

We need the keyboard navigation in both cases. Anything i can do to fix this?

We are on version 4.4.0.51, .net 2.0

Thanks,
Julie

Grid_MultiSelect4.zip

haneefm [Syncfusion]
Replied On April 30, 2007 05:55 PM

Hi Julie,

A change has been made in hidden column logic from Essential Studio v4.4 to improve the performance of the grid. It causes some navigation problem while setting the Properties.RowHeaders = False (or) HideCols[0] = true . To resolve this, you need to set the UseOldHiddenScrollLogic property to TRUE in the GridControlBase.

//Form1 constructor.
GridControlBase.UseOldHiddenScrollLogic = true;

Best regards,
Haneef

Julie Levy
Replied On May 1, 2007 02:59 PM

Thanks Haneef... this one has been driving me crazy for weeks.
Is this fixed in the latest release? or will this setting still be required? Does having this setting slow down performance?

Julie

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;