We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Border around selected cells does not render correctly

Thread ID:

Created:

Updated:

Platform:

Replies:

59838 Apr 23,2007 04:42 PM Jul 17,2007 01:31 PM Windows Forms 9
loading
Tags: GridControl
Brian Richards
Asked On April 23, 2007 04:42 PM

Using virtual grid in version 4.402.0.51.

I'm having issues with the selection border being drawn incorrectly around selected cells. I can't seem to find anything in my code that directly alters the drawing of the border. The cell backgrounds are highlighted correctly though. Also the border issues is exaggerated the bigger i make my header rows. I've attached two screenshots that demonstrate what I'm talking about.

Thanks

BorderProblem.zip

Rajagopal [Syncfusion]
Replied On April 23, 2007 07:36 PM

Hi Brian,

It seems you are having excel like selection for your grid cells by setting these properties.

this.gridControl1.ExcelLikeCurrentCell = true;
this.gridControl1.ExcelLikeSelectionFrame = true;

The selection border is correctly drawn around the selected cells without any issues. We are not able to see this problem in any our samples, by having the above mentioned properties set. It would be helpfull if you could describe this issue with some steps to reproduce here?

Thanks,
Rajagopal

Brian Richards
Replied On April 24, 2007 10:16 AM

It looks like the issue I'm having related to a combination of frozen and hidden rows. I have a grid with 2 column header rows. The first one is set to hidden (gridControl.HideRows[0] = true;) and FrozenCount is set to 1 (gridControl.Rows.FrozenCount = 1;)

If I don't set either of the two properties the excel style cell selection is drawn correctly.

Are there any other particular properties or settings I can check to see where I may be misusing something? I can't seem to replicate it in a stand alone app so I'm trying to see where else I should be looking.

Thanks

>Hi Brian,

It seems you are having excel like selection for your grid cells by setting these properties.

this.gridControl1.ExcelLikeCurrentCell = true;
this.gridControl1.ExcelLikeSelectionFrame = true;

The selection border is correctly drawn around the selected cells without any issues. We are not able to see this problem in any our samples, by having the above mentioned properties set. It would be helpfull if you could describe this issue with some steps to reproduce here?

Thanks,
Rajagopal

Brian Richards
Replied On April 24, 2007 11:14 AM

In fact it looks like it ends up subtracting the height of the Column Header row that is visible from the excel style border.

>Hi Brian,

It seems you are having excel like selection for your grid cells by setting these properties.

this.gridControl1.ExcelLikeCurrentCell = true;
this.gridControl1.ExcelLikeSelectionFrame = true;

The selection border is correctly drawn around the selected cells without any issues. We are not able to see this problem in any our samples, by having the above mentioned properties set. It would be helpfull if you could describe this issue with some steps to reproduce here?

Thanks,
Rajagopal

Rajagopal [Syncfusion]
Replied On April 24, 2007 08:09 PM

Hi Brian,

Thanks for your update. We are able to see this problem now. We are currently working on your issue and will let you know the details soon.

Thanks,
Rajagopal

Madhankumar [Syncfusion]
Replied On April 25, 2007 03:26 PM

Hi Brain,

Please try setting Properties.ColHeaders property to false, this helps to achieve the intend behavior. The following is the code snippet.

+++++++++++++++++++
gridControl1.Properties.ColHeaders = false;
//gridControl1.HideRows[0] = true;
+++++++++++++++++++

Kindly let us know if you need any further assistance.
Have a nice day.

Best regards,
Madhan

Brian Richards
Replied On April 26, 2007 08:30 AM

This won't work because I have two column header rows and I'm only trying to hide the top most one.

>Hi Brain,

Please try setting Properties.ColHeaders property to false, this helps to achieve the intend behavior. The following is the code snippet.

+++++++++++++++++++
gridControl1.Properties.ColHeaders = false;
//gridControl1.HideRows[0] = true;
+++++++++++++++++++

Kindly let us know if you need any further assistance.
Have a nice day.

Best regards,
Madhan

Madhankumar [Syncfusion]
Replied On April 26, 2007 12:06 PM

Hi Brian,

Thanks for your response.

The following sample shows the alternative technique to achieve the intended behavior. In the sample, ExcelLikeThickBorderSelection is drawn by hanlding the CellDrawn, PrepareviewstyleInfo and SelectionChanging events accordingly to avoid this behavior.

Please refer to the following sample and let us know if you need any further assistance.
http://websamples.syncfusion.com/samples/Grid.Windows/I59838_26April07/main.htm

Have a nice day.

Best regards,
Madhan

Madhankumar [Syncfusion]
Replied On July 10, 2007 02:22 PM

Hi Brain

Thank you for being patience. This issue is still under development, we will let you know the complete details once we get back with information from our development team.

Have a nice day.

Best regards,
Madhan

Madhankumar [Syncfusion]
Replied On July 17, 2007 01:31 PM

Hi Brain,

Thank you for being patience. There are some complicated issues with setting Row/Col Hidden[index] to true. For now you can avoid this issue by setting the height/width to 0 instead of setting Hidden to true.

As for as now, there is no ETA for this fix. And it can be workaround by just setting Widths/Height which will work the same way, setting Hidden to true works. Sorry for any inconvenience caused.

Best regards,
Madhan

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;