We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Summary Row Problem

Thread ID:

Created:

Updated:

Platform:

Replies:

59296 Apr 10,2007 04:08 PM UTC Apr 11,2007 09:30 AM UTC Windows Forms 2
loading
Tags: GridControl
Aditi Pisal
Asked On April 10, 2007 04:08 PM UTC

Hi,
I am using grid grouping control version
4.4.0.55
I have to put summary at the top position of the grid and not at bottom.
Attached is sample requirement.
Pls Help.
Thanks in Advance
Aditi Pisal

DeleteCellValue_SummaryColumn.zip

Administrator [Syncfusion]
Replied On April 10, 2007 05:25 PM UTC

You can do this by putting the summaries in the CaptionRow. We ship one sample that shows this, Grid.Grouping.Windows\Samples\Summaries\SummaryIncaption.

Here is a more minimal sample that does it.

http://www.syncfusion.com/Support/user/uploads/WindowsApplication126_cbb8d3b1.zip

Aditi Pisal
Replied On April 11, 2007 09:30 AM UTC

Hi Clay,
Thanks for the solution.
But I have another problem..
I have implemented Covered Ranges to cover few columns ...Now This caption row comes above the covered cells .
I am using custom engine to prepare the covered ranges and setting few properties in it.

I want to make use of the
'ShowAddNewRowBeforeDetails ' to display the summary values.

Since all my records are prepopulated and theer is no data entry..
I can use the 'ShowAddNewRowBeforeDetails ' at the above position which will be below the covered ranges and above the data.
Pls help with sampkle exe.

Thanks in Advance.
Aditi




DeleteCellValue_SummaryColumn0.zip

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;