We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

MultiColumnComboBox broken in 5.1 beta

Thread ID:

Created:

Updated:

Platform:

Replies:

59183 Apr 5,2007 05:38 PM Apr 9,2007 09:37 AM Windows Forms 4
loading
Tags: Tools
Keith Steinbeck
Asked On April 5, 2007 05:38 PM

Hello,

I have code that worked fine (and in fact was suggested by Syncfusion) under 4.x that is now broken under 5.1 beta.

In short, operations - called before the parent form is shown - involving a MultiColumnComboBox's ListBox will fail because the ListBox is null.

For example, a form contains only a MCCB. In the form's ctor after InitializeComponent(), trying to add an EventHandler to the MCCB's ListBox will fail because it is null.

However, if the EventHandler is added after the form is displayed (via the click handler of a button for example) no exception is thrown.

I've attached a small project that demonstrates this behavior.

Using 4.x there were no such problems.

Is this a bug or are we supposed to initialize the ListBox outselves somehow? Please advise.

Keith

ComboBoxTest0.zip

Murugan [Syncfusion]
Replied On April 5, 2007 05:53 PM

Hi Keith,

Sorry for the inconvenience caused. We could reproduce the issue as you mentioned.Could you please create a Direct-Trac incident with the subject line "MultiColumnComboBoxAdv problem - F59183" so that we can give more details regarding the fix?

Thanks for your interest in Syncfusion products.

Best Regards,
Murugan P.S

Son Nguyen
Replied On April 5, 2007 06:16 PM

Same thing has happened to us..

When we installed the new version our project will not compile..On my case it doesn't find
syncufision.windows.forms so nothing works..I added the dll to the toolbar so that it can generate everything and droped a control but it still wont recognize it..

Keith Steinbeck
Replied On April 6, 2007 01:36 PM


>Hi Keith,

Sorry for the inconvenience caused. We could reproduce the issue as you mentioned.Could you please create a Direct-Trac incident with the subject line "MultiColumnComboBoxAdv problem - F59183" so that we can give more details regarding the fix?

Thanks for your interest in Syncfusion products.

Best Regards,
Murugan P.S

Done. The incident# in the email I received is 33181.

Murugan [Syncfusion]
Replied On April 9, 2007 09:37 AM

Hi Keith,

Thanks for your update. We have forwarded this issue to our development team. Our development team engineer will take care of this incident and update the issue details and timeframe needed to fix the issue in 2 days of time .

Regards,
Murugan P.S

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;