We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

GGC with 3 levels

Thread ID:

Created:

Updated:

Platform:

Replies:

55774 Feb 5,2007 06:40 AM Feb 5,2007 11:56 AM Windows Forms 5
loading
Tags: GridControl
John H
Asked On February 5, 2007 06:40 AM

Hi,
Seeing a strange problem when navigating a GGC when a node has child rows, and those child rows have their own child rows. Selecting these child rows sometimes causes the GGC to scroll up or down, and often doesn't highligh the row that was clicked.

Any ideas? I'll try to cut this down to a simple example and will post a zip later.

Thanks
John

John H
Replied On February 5, 2007 07:05 AM

Hi,
I have found that the problem is with the way I am forcing the entire row to be highlighted via the TableControlCurrentCellActivating event, I am setting e.Inner.ColIndex = 0;

Can you please advise how I can highlight the entire selected row, without setting this property?

Thanks
John


>Hi,
Seeing a strange problem when navigating a GGC when a node has child rows, and those child rows have their own child rows. Selecting these child rows sometimes causes the GGC to scroll up or down, and often doesn't highligh the row that was clicked.

Any ideas? I'll try to cut this down to a simple example and will post a zip later.

Thanks
John

Administrator [Syncfusion]
Replied On February 5, 2007 08:05 AM

Try these settings:

grid.TableOptions.ListBoxSelectionMode = SelectionMode.One;
grid.TableOptions.AllowSelections = GridSelectionFlags.None;
grid.TableOptions.ListBoxSelectionCurrentCellOptions = GridListBoxSelectionCurrentCellOptions.None;

John H
Replied On February 5, 2007 09:35 AM

Hey Clay,
I tried that but still get a black border around the selected cell, any way of switching that off?

I also need ListBoxSelectionMode to be MultiSelected, if that makes a difference.

Thanks
John

>Try these settings:

grid.TableOptions.ListBoxSelectionMode = SelectionMode.One;
grid.TableOptions.AllowSelections = GridSelectionFlags.None;
grid.TableOptions.ListBoxSelectionCurrentCellOptions = GridListBoxSelectionCurrentCellOptions.None;

Administrator [Syncfusion]
Replied On February 5, 2007 11:25 AM

Try changing the GridListBoxSelectionCurrentCellOptions.None to HideCurrentCell.
gridGroupingControl1.TableOptions.ListBoxSelectionCurrentCellOptions = GridListBoxSelectionCurrentCellOptions.HideCurrentCell;


John H
Replied On February 5, 2007 11:56 AM

Hi Clay,
GridListBoxSelectionCurrentCellOptions.HideCurrentCell doesn't exist, but I found another property that does what I need.

ggc.TableModel.Options.ShowCurrentCellBorderBehavior = GridShowCurrentCellBorder.HideAlways;

Cheers
John

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;