We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

EditControl - LoadStream() Exception

Thread ID:

Created:

Updated:

Platform:

Replies:

55073 Jan 23,2007 06:12 PM UTC Feb 2,2007 05:37 PM UTC Windows Forms 5
loading
Tags: EditControl
dwedewdew
Asked On January 23, 2007 06:12 PM UTC

Hi,

I'm using Syncfusion 4.3.0.30 on WinXp SP2.

When loading a file stream into the editcontrol via the LoadStream() method a SystemStackOverflow exception is thrown. I think that this only happens if the stream doesn't end with CRLF or 0D 0A!

I think this is related to "Defect #1385 - EditControl does not display the last line in a file which does not terminate with CRLF".

I attached a sample with illustrates the issue.
I also need a bugfix or workaround for this. Using the LoadFile() method is not an option.

Yours

Christian

CRLF_BUG.zip

Administrator [Syncfusion]
Replied On January 30, 2007 02:31 AM UTC

Hi Christian,

Our apologies for the delayed response. We are looking in to this issue and will update you with more information within a day.

Thanks for your patience.

Regards,
Ebenezer.P

Christian Teufel
Replied On January 31, 2007 09:22 AM UTC

Hi,

any news about this issue?
Is there a possible workaround

Yours

Christian!

Administrator [Syncfusion]
Replied On January 31, 2007 07:18 PM UTC

Hi Christian,

It is possible to workaround this issue. I have attached a sample that illustrates this. Let me know if this meets your requirements.

Thanks for your patience.

Regards,
Ebenezer.P

sample

dwedewdew
Replied On February 2, 2007 01:02 PM UTC

Hi,

thanks for the workaround.
However, this will only suffice for small files.
It seems that setting the text property directly ignores all perfomrance improvements you developed.

Thus, opening large files (e.g. > 10000 lines) causes extrem performance loss on file loading.
I attached a sample file, please try yourself.

Is there another workaround or maybe a fix?!?!

Yours

Christian!



preprocessed.zip

Purusothaman R [Syncfusion]
Replied On February 2, 2007 05:37 PM UTC

Hi Christian,

We regret for the inconvenience caused.

To increase the performance of the Edit Control when loading a larger file, you can set the ParsingMode to PartialParsingNoFallback as follows.

this.editControl1.ParsingMode = Syncfusion.Windows.Forms.Edit.Enums.TextParsingMode.PartialParsingNoFallback;

Also I have attached a Sample. Please look in to the sample.

CRLF_BUG.zip

Thanks for your interest in Syncfusion Products.

Regards,
Purusothaman.R

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;