We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

GridGroupingControl - Dbl Click, Opens the Form Behind the Grid

Thread ID:





51392 Nov 3,2006 05:36 PM UTC Nov 6,2006 02:55 PM UTC WinForms 4
Tags: GridControl
Badri Rajani Kanth
Asked On November 3, 2006 05:36 PM UTC


We are using V

I have a main form with GGC. Each time we double click on any record in GGC, I should pop-up aform. These pop-up forms should first should open top of main form. But when we click on grid, main form should be on top of all. That means, we can not set main form as owner to these pop-up forms.

Now the issue is, when we double click, while pop-up is being opened, grid is getting activated and main form is displayed on top. Thus pushing back the pop-up. this can be because of small movement in cursor while double click.

I have attached a sample to demonstrate this.
Please try to double click on many places in the grid (ex cell corners). Some times you can observe the pop-up being opened behind the main form. This is not observed when you open pop-up using a button click. Itz only because of grid getting activated.

How can we solve this issue?

Rajani kanth


Administrator [Syncfusion]
Replied On November 6, 2006 04:20 AM UTC

Hi Rajani,

Try setting the TopMost property of the form to TRUE. Here is a code snippet

Form2 form2 = new Form2();
form2.TopMost = true;

Let me know if this helps.

Best Regards,

Badri Rajani Kanth
Replied On November 6, 2006 10:28 AM UTC

Thank You Haneef,

But if we make it top most, if click on the parent form grid again, pop-up will NOT go behind the parent form. As I said earlier, I should be opening multiple pop-ups, by double clicking on grid records. Pop-up should open on top of grid only for the first time. Next time when I click on grid, all pop-ups should go behind. Again when I double click on record, new pop-up should be displayed on top. This is possible with a button in main form. But problem exists with grids. You can observe this in the sample.

Can you plz look into this?

Rajani Kanth

Administrator [Syncfusion]
Replied On November 6, 2006 12:24 PM UTC

Hi Rajani,

I have created the sample as per your requirement. The attached sample implements the timer component to resolve this issue. Please try the sample and let me know if this helps.

Here is a sample.

Best Regards,

Badri Rajani Kanth
Replied On November 6, 2006 02:55 PM UTC

Hi Haneef,

We are already using similar timer fix. We want to know some thing, make grid not activated till the time child form is loaded (stop raising all grid events). Again this also can be done by a timer.

Is there any other fix?

Rajani Kanth


This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon