We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

How to make ggc look like windows listview control (readonly, ect)

Thread ID:

Created:

Updated:

Platform:

Replies:

50822 Oct 19,2006 05:48 PM UTC Nov 23,2006 05:01 AM UTC Windows Forms 8
loading
Tags: Grouping
jamesb
Asked On October 19, 2006 05:48 PM UTC

How can I make the ggc look behave like a list view control with readonly static cells, ect

Administrator [Syncfusion]
Replied On October 20, 2006 10:48 AM UTC

Try setting these properties to see if that does what you want.

this.gridGroupingControl1.DataSource = dt;

this.gridGroupingControl1.TableDescriptor.Appearance.AnyRecordFieldCell.CellType = "Static";
this.gridGroupingControl1.TableOptions.ShowRowHeader = false;
this.gridGroupingControl1.TableDescriptor.AllowNew = false;
this.gridGroupingControl1.TableOptions.ListBoxSelectionMode = SelectionMode.One;
this.gridGroupingControl1.TableOptions.ListBoxSelectionCurrentCellOptions = GridListBoxSelectionCurrentCellOptions.HideCurrentCell;
this.gridGroupingControl1.TableModel.Options.ShowCurrentCellBorderBehavior = GridShowCurrentCellBorder.HideAlways;
this.gridGroupingControl1.TopLevelGroupOptions.ShowCaption = false;

jamesb
Replied On November 9, 2006 03:33 AM UTC

For some strange reason, the first column is still editable. The rest of the other columns are read-only!

Administrator [Syncfusion]
Replied On November 9, 2006 12:09 PM UTC

Hi James,

Is it possible for you to upload us more details/sample or modify the attached sample to reproduce the issue here? This will help us to analyse the issue further.

Sample : http://www.syncfusion.com/Support/user/uploads/GGCListControl_1e48dd8c.zip

Best regards,
Haneef

jamesb
Replied On November 9, 2006 12:50 PM UTC

I noticed that when I set the grid properties BEFORE I bind the ggc, then I experienced the problem with the first column being editable when I double-clicked in the cell.

However, when I set the ggc properties AFTER I bind the grid like in your example, it works as intended.


Administrator [Syncfusion]
Replied On November 9, 2006 01:09 PM UTC

Hi James,

We have no other reports of this issue, and have not seen it in our system. Let us know the below information for analysing the issue further.

1) Exactly what version of Windows XP are you using?
2) Are you only installing Essential Grid or are you installing Essential Studio? Are you installing binaries only, or the source code version, or eval version?
3) What version of the .NET framework and VS are you using? Has this system had any of the .NET 2.0 betas installed on it?
4) Have you seen this on multipple systems?
5) Did you see any errors during the installation of Essential Grid?

Thanks for your patience.

Best Regards,
Haneef

jamesb
Replied On November 9, 2006 02:49 PM UTC

1) Exactly what version of Windows XP are you using?
2) Are you only installing Essential Grid or are you installing Essential Studio? Are you installing binaries only, or the source code version, or eval version? Essential Studio, Binaries, license version
3) What version of the .NET framework and VS are you using? Has this system had any of the .NET 2.0 betas installed on it? vs.net 2005 on .net 2.0, no betas
4) Have you seen this on multiple systems? currently only working in dev mode on my box, windows xp2 sp2
5) Did you see any errors during the installation of Essential Grid? no

on another note, now that it works, I have a couple of question related to the this list view look-
1. when i select a record, and do a sort by clicking on the column header, the selection marker does not move with the currently selected record, but remain static at the current position.

1. how do I remove the selection thru code?

jamesb
Replied On November 9, 2006 11:12 PM UTC

I have the ggc behaving like a listbox. I have a checkbox in the header and have the first column as a checkbox field, following the example in this forum (bounded checkbox in ggc).

However, when I clicked the checkbox, it is not checked. The row is selected, but the check box is not checked. is this this because AnyCell is set to 'Static'.

I do not think this should be happening since I have this line below

this.gridGroupingControl.TableDescriptor.Columns["FirstColumn"].Appearance.AnyRecordFieldCell.CellType = "CheckBox";

can you all help?

Administrator [Syncfusion]
Replied On November 23, 2006 05:01 AM UTC

Hi James,

The reason is that you are setting the ListBoxSelectionCurrentCellOptions property to GridListBoxSelectionCurrentCellOptions.HideCurrentCell. It doesn't select the current cell in a Grid. But you can do this by handling the TableControlPrepareViewStyleInfo event. Please try the attached sample and let me know if this helps.

Sample : < a rel='nofollow' href="http://www.syncfusion.com/Support/user/uploads/GGCCheckBox_c0bb1976.zip"> CheckBox

Best Regards,
Haneef

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;