We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

DeviceContext related error in tab control

Thread ID:

Created:

Updated:

Platform:

Replies:

47438 Aug 4,2006 05:59 AM Jan 2,2008 05:45 AM Windows Forms 3
loading
Tags: Tools
Administrator [Syncfusion]
Asked On August 4, 2006 05:59 AM

I am occasionally getting "System.ArgumentException: Parameter is not valid" at System.Drawing.Graphics.GetHdc() inside the "Syncfusion.Windows.Forms.Tools.TabRendererBase.DrawText(...)" function.

The effect of the above execption is that a red cross appears over the entire tab area of the TabControlAdv. Interesting is that the TabPage is still rendered correctly.

I cannot repeat the problem but I have a tabcontrol where I frequently add and remove pages and tabs (dynamically based on some object type)

Does anyone experience similar problem or perheps such a fix included in 4.2.0.60 (in new service pack)?

Administrator [Syncfusion]
Replied On August 7, 2006 02:58 AM

Hi Zoltan,

I am afraid , I have tested this issue in v4.2.0.60 and was not able to reproduce the problem. I have attached my test sample.

tabtest.zip


Please take a look and let me know if you see the problem in this attached sample or modify this sample to reproduce the issue.

Thanks for your using Syncfusion products.

Best Regards,
Seetha

Gary
Replied On October 23, 2007 10:47 AM

Hi, I'm seeing this problem too. Did you ever figure out what caused it? It only seems to happen when a user switches tabs or forms very quickly.

>I am occasionally getting "System.ArgumentException: Parameter is not valid" at System.Drawing.Graphics.GetHdc() inside the "Syncfusion.Windows.Forms.Tools.TabRendererBase.DrawText(...)" function.

The effect of the above execption is that a red cross appears over the entire tab area of the TabControlAdv. Interesting is that the TabPage is still rendered correctly.

I cannot repeat the problem but I have a tabcontrol where I frequently add and remove pages and tabs (dynamically based on some object type)

Does anyone experience similar problem or perheps such a fix included in 4.2.0.60 (in new service pack)?

Bhuvaneswari P [Syncfusion]
Replied On January 2, 2008 05:45 AM

Hi Zoltan,

Thanks for the update.

Argument Exception: when user switches tabs or forms very quickly.

We are still not able to reproduce the issue, we tried repeat to switching between the tabs and forms, but not able to reproduce the issue.

Please take a look into the video file for your reference:
http://websamples.syncfusion.com/samples/Tools.Windows/F47438/main.htm

Could you please modify the sample or provide your sample to reproduce the issue, so that we can be able to reproduce the issue and investigate further on this issue and could you please provide your system configuration too.

Please let me know if you have any other questions.

Best Regards,
Bhuvana



CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;