We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Syncfusion controls on the form was disappeared.

Thread ID:

Created:

Updated:

Platform:

Replies:

45678 Jun 26,2006 09:21 PM Dec 2,2006 01:01 AM Windows Forms 11
loading
Tags: Tools
Jeong-Seok Yang
Asked On June 26, 2006 09:21 PM

I can not see the existance of the Syncfusion control on the form. But I can see it in the code like the below. What is the matter ? What Should I do ? private Syncfusion.Windows.Forms.Tools.XPMenus.MainFrameBarManager mainFrameBarManager1; private Syncfusion.Windows.Forms.Edit.EditControl editControl_Result; Syncfusion Version : 4.1.0.51 Compiler Version : Visual Studio 2003 korean version

Jeong-Seok Yang
Replied On June 26, 2006 10:01 PM

And also I can not add the control to the form. with the popup Syncfusion.Windows.Forms.Edit.EditControl의 인스턴스를 만드는 동안 예외가 발생했습니다. 예외는 "Syncfusion.Windows.Forms.Edit.Implementation.Config.Config"의 형식 이니셜라이저에서 예외를 Throw했습니다."입니다. If I translate it into English. Exception occured while creating the instance of Syncfusion.Windows.Forms.Edit.EditControl. The exception is ""Syncfusion.Windows.Forms.Edit.Implementation.Config.Config"''s Initializer throw the exception" What is wrong ? a few days ago I used license enabler from the syncfusion program group. Does it affect it ? Please tell me what I have to do.

J.Nagarajan [Syncfusion]
Replied On June 27, 2006 05:57 AM

Hi Jeong, This problem typically occurs when multiple versions of Syncfusion assemblies are present on a machine. Somehow the application gets built against one version and links to different version at runtime thereby leading to unpredictable behavior. Here are a few suggestions we have on the problem you are encountering: 1. Do you have more than one version of Essential Suite installed on your machine? 2. Can you check the references of your project and see that they are of the correct version - v4.1.0.51? 3. Do you have the CopyLocal property set to true for the Syncfusion references in the designer ? If so, can you try setting it to false and see if it helps? 4. Please go to your GAC (C:\WINDOWS\assembly folder) and delete all the Syncfusion and Syncfusion policy dlls. Then run the Assembly Manager from the Start Menu (Start->Programs->Syncfusion->Essential Suite->Assembly Manager) and choose Default-Prebuilt option (which refers to the latest version on your machine). This will update your GAC with the proper dlls. Please try these and let me know how it goes. We appreciate your cooperation, and thanks for choosing Syncfusion. Regards J.Nagaraj

Jeong-Seok Yang
Replied On June 27, 2006 09:02 AM

Thanks for you Answer. But still I am in troble. 1 and 2. I just one version v4.1.0.51 and I have never installed any updates. 3. As you said, I set CopyLocal property to false. 4. I uninstalled all of syncfusion assembly and updated with Assembly Manager As you mentioned. After followed your direction, I could add Syncfusion controls to the form But previous controls were not visible Though code sill exists. And There are two projects in the one solution. one project is in trouble. But controls on another project was not disappeared. and It works well.

J.Nagarajan [Syncfusion]
Replied On June 27, 2006 11:44 AM

Hi Jeong, Sorry for the inconvenience.Please Make sure that the contents of the Isolated Storage folder are deleted before you begin the test. The Isolated Storage folder is in the directory C:\Documents and Settings\{user name}\Local Settings\Application Data\IsolatedStorage. Please let me know if this works for you. Regards, J.Nagaraj.

Jeong-Seok Yang
Replied On June 27, 2006 10:08 PM

It does not work. Have you ever seen a similar phenomenon ?

J.Nagarajan [Syncfusion]
Replied On June 28, 2006 10:34 AM

Hi Jeong, My sincere apologies for the inconvenience. If it is possible for you to send us the mainfrom class file and resx file containing Syncfuson XPMenus, could you please create a Direct-Trac incident and send us the files so that we can have a look at the code to provide a solution. Please provide this forum link in the subject line. Thanks for your patience and understanding on this issue. Regards, Mano

Jeong-Seok Yang
Replied On July 3, 2006 12:04 AM

I extracted the project. Could you check it, please. you can download the project from the below. http://www.bioneer.co.kr/download/Problem.zip and open \ExiLCTCfg\ExiLCTCfg.sln Thanks.

Problem1.zip

J.Nagarajan [Syncfusion]
Replied On July 3, 2006 12:09 PM

Hi Jeong, Thanks for your sample. We have noticed the loss of Menus code when CopyLocal property is set to true and then set to false. This isbecause, when the CopyLocal is set to true, the exe file in the application will look for references in both the GAC as well as the local folder, possibly leading to a conflict and hence the application might show unpredictable behavior.We have forwarded this issue to our development team and will update you regarding this at the earliest. But for now, you have to create menus again from the scratch with CopyLocal set to false. Please let me know if you have any questions. Thank you, J.Nagaraj

Jeong-Seok Yang
Replied On July 10, 2006 03:59 AM

Can I receive the update within this month ? Could you tell me when ? It''s very annoying to me..

J.Nagarajan [Syncfusion]
Replied On July 10, 2006 12:18 PM

Hi Jeong, We have logged a bug report # 2363 in this regard. You can track the progress of this issue at this link below : Defect #2363-Menus and Toolbars get disappeared when the CopyLocal property of all syncfusion dlls is set to true We will fix this issue at the earliest and keep you informed. Thanks for your patience. Regards, J.Nagaraj.

honda accessories
Replied On December 2, 2006 01:01 AM

Butcher the second remark i dont know thatthat is i dont. truck wheel harley choppers dakota truck [url=http://members.lycos.co.uk/topblog/dakota-truck.htm#dakota+truck]dakota truck[/url] dodge floor mats cargo truck [url=http://members.lycos.co.uk/topblog/cargo-truck.htm#cargo+truck]cargo truck[/url]

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;