We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.


Thread ID:





45619 Jun 26,2006 03:24 AM Jun 27,2006 08:18 PM Windows Forms 5
Tags: GridControl
Leow Kah Man
Asked On June 26, 2006 03:24 AM

What is the purpose of GridControl.DefaultGridBorderStyle? I tried to change this to NotSet and None on one of the samples; CellStyles_2005. However, I still see grid lines. What is the best way to toggle showing/hiding grid lines on GridControl? Is it using the above way or using GridControl.Properties.DisplayHorzLines?

Leow Kah Man
Replied On June 26, 2006 03:28 AM

Or use BaseStyles?

Administrator [Syncfusion]
Replied On June 26, 2006 11:59 AM

Hi Leow, I have tested this issue by creating a sample using GridControl in v.4.1 and then again tested by upgrading to 4.2. I was not able to reproduce the issue. Maybe I am not following the steps that you are doing. Attached sample working fine here. If you can provide more information, we can try to suggest some solution. Here is a sample http://www.syncfusion.com/Support/user/uploads/CellStyles_94f8e703.zip Could you please run this at your end and let me know how it goes? Thanks for your patience. Best Regards, Haneef Note : The GridStyleInfoAtWork browser sample shows you the relationship between a standard style, the table style, a basestyle, a row style, a column style and a cell style. It lets you set a border for each one of these, and lets you choose whether or not you want the style included. While working with these options, you will be able to see the precedence relationship among the style. Here is a link \Syncfusion\Essential Studio\\windows\Grid.Windows\Samples\Quick Start\GridStyleInfoAtWork\

Leow Kah Man
Replied On June 26, 2006 08:56 PM

You set it during Form1_Load, Try setting it via Visual Studio 2005 GUI.

Administrator [Syncfusion]
Replied On June 27, 2006 12:39 PM

Hi Leow, The reason is that you are setting the DefaultGridBorderStyle property to GridBorderStyle.Solid in the form1.cs''s Form1 constructor. After commenting the below line, It works fine. //File- > form1.cs : Line No 285. //this.gridControl1.DefaultGridBorderStyle = GridBorderStyle.Solid; Let me know if this helps. Best Regards, Haneef

Leow Kah Man
Replied On June 27, 2006 08:18 PM

Oh, I didn''t notice that. No wonder. Thank you.


This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.