We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

4.2 GGC ColumnDescriptor Designer bug

Thread ID:

Created:

Updated:

Platform:

Replies:

45284 Jun 15,2006 12:25 PM Jun 28,2006 03:49 PM Windows Forms 4
loading
Tags: GridControl
Administrator [Syncfusion]
Asked On June 15, 2006 12:25 PM

Just upgraded to 4.2. While defining a ColumnDescriptor in the designer I get an exception. Please try to reproduce the folowwing steps: 1. Drop GGC on the Form. 2. TableDescriptor->Columns 3. Type mapping name and set AllowFilter=True 4. Click OK System.NullReference exception is displayed in the GGC placeholder. Thank you

Administrator [Syncfusion]
Replied On June 16, 2006 01:06 AM

Hi, Because of the dynamic / late binding characteristics of the engine it is sometimes really hard to track down where you might have misspelled a mapping-name(Name). Access of the ColumnDescriptorCollection can be triggered by various methods within the library itself. The warning will help you if you have trouble with the column descriptor. But the warning might also be no issue at all, e.g. if you set the MappingName of the columnDescriptor later or if you add the Field becomes added later (e.g. if DataSource is set later than the ColumnDescriptor was accessed ). Note : To resolve this issue, you MUST set the datasource property of the grid before accesing the ColumnDescriptor. Let me know if you need any further assistance. Best Regards, Haneef

Administrator [Syncfusion]
Replied On June 27, 2006 02:25 PM

I''m "accessing" column descriptor through a designer! I also do not use either strongly typed datasets or custom collections - so I can not set the datasource in advance. All I do is setting a mapping name and allowing filter on a columndescriptor. This used to work in 4.1 with no problems. Please reproduce the steps I have described and you will see what the the problem is. Thank you

Administrator [Syncfusion]
Replied On June 27, 2006 04:47 PM

Hi, We are currently looking into this issue and will update you the details. Thanks for your patience. Best Regards, Haneef

Administrator [Syncfusion]
Replied On June 28, 2006 03:49 PM

Hi, We regret very much for the inconvienience caused. I was able to reproduce the issue as you said. I have logged a bug report in our Defect Management System regarding this and we will try our very best to fix this issue at the earliest. You can track the progress of bug fix through the below given link. http://www.syncfusion.com/support/issues/grid/Default.aspx?ToDo=view&questId=2302 Thanks for your patience. Best Regards, Haneef

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;