We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Problems with changing link shapes.

Thread ID:

Created:

Platform:

Replies:

44479 May 24,2006 10:13 AM Windows Forms 0
loading
Tags: Diagram
Henrik Strömberg
Asked On May 24, 2006 10:13 AM

Hi, We have implemented a solution where we can change link shapes, e.g. from directed lines to orthogonal lines, from a context menu. This works fine, except from the fact the tha symbols have to be moved at least one pixel in order for the link to be aligned to the symbol edge and not to the center port. We have the AttachToPerimeter property set to true for the symbol. What we are doing is this: We first layout all the symbols, and thereafter it''s possible to change link shapes, without updating the layout. But as mentioned, in order for the links to really attach to the symbol''s perimeter and not to the center port of the symbol, we have to move the symbol. Is this a bug, or is there a solution for this problem, that doesn''t involve moving the symbol or link? / Henrik Stromberg

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;