We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

GGC : How do I set the AllowSortColumns property for a nested table

Thread ID:





39294 Jan 4,2006 04:09 AM UTC Jan 4,2006 08:03 AM UTC WinForms 2
Tags: Grouping
Asked On January 4, 2006 04:09 AM UTC

I need to set the AllowSortColumns property for a nested table to false. How can I do this programmatically? None of the TableDescriptor properties for the nested table provide this option. Thanks, Anupama

stanleyj [Syncfusion]
Replied On January 4, 2006 06:53 AM UTC

Hi Anupama, To turn off the sorting for the GGC, the AllowSortColumns must be set to false. this.gridGroupingControl1.TableOptions.AllowSortColumns = false; If you do not wish to sort nested tables alone, then cancel the click action in the TableControlCellClick for all table names other than the top level table. private void gridGroupingControl1_TableControlCellClick(object sender, GridTableControlCellClickEventArgs e) { if(e.TableControl.TableDescriptor.Name != this.gridGroupingControl1.TableDescriptor.Name) e.Inner.Cancel = true; } Best regards, Stanley

Replied On January 4, 2006 08:03 AM UTC

Thanks. It worked another way. I set the following this.gridGroupingControl1.TableDescriptor.TableOptions.AllowSortColumns = false; this.gridGroupingControl1.TableOptions.AllowSortColumns = false; The first line sets the option for nested tables and the second one for top level table. Thanks.


This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

or the page will be automatically redirected to sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon