We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : Nov 16th 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Diagram Symbol Designer Crashing...

Thread ID:

Created:

Updated:

Platform:

Replies:

39036 Dec 23,2005 06:06 AM UTC Dec 27,2005 09:55 PM UTC WinForms 2
loading
Tags: Diagram
David Llewellyn
Asked On December 23, 2005 06:06 AM UTC

Hello. I have created this custom symbol, which has an image inserted as part of it. When I now load it into the Diagram Symbol Designer and click on it with the left mouse button, the designer crashes. I tried to create a new symbol ( a rectangle, with the image in and then group them together). Now when I try to resize the symbol, the image "jumps" out of the rectangle and after resizing the symbol a few times, the designer crashes. This is the same behaviour of my projects diagram control. Is this a bug in the diagram control? Thanks, David.

NodeWithRed.zip

Administrator [Syncfusion]
Replied On December 27, 2005 09:41 PM UTC

>Hello. > >I have created this custom symbol, which has an image inserted as part of it. When I now load it into the Diagram Symbol Designer and click on it with the left mouse button, the designer crashes. > >I tried to create a new symbol ( a rectangle, with the image in and then group them together). Now when I try to resize the symbol, the image "jumps" out of the rectangle and after resizing the symbol a few times, the designer crashes. This is the same behaviour of my projects diagram control. > >Is this a bug in the diagram control? > >Thanks, >David.

NodeWithRed.zip

Administrator [Syncfusion]
Replied On December 27, 2005 09:55 PM UTC

Hi David, Resizing a symbol containing a BitmapNode inside the Essential Diagram SymbolDesigner was causing node selection to be affected in an earlier version of the product. This issue has since been fixed. I ran a few tests with your symbol palette using the new 4.1.0.10 beta codebase. Both the Essential Diagram SymbolDesigner and the DiagramBuilder sample application that I used for my tests were able to load and work with the symbol without any problems. Clicking or moving the symbol does not cause either application to crash. I did however notice that grouping the bitmap and ellipse nodes together inside the SymbolDesigner(as you have done) and resizing the symbol instance in a diagram application was interfering with node selection. This condition can be avoided by not grouping the nodes together inside the symbol designer. Upgrading to new 4.1.0.10 beta should take care of the issues that you have mentioned. Please let me know if the problem persists despite the upgrade. Regards, Prakash Surendra Syncfusion Inc.,

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;