We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

GridExcelConverterControl does not include header row on export of GDBG

Thread ID:

Created:

Updated:

Platform:

Replies:

38620 Dec 15,2005 10:32 AM Feb 21,2006 03:42 AM Windows Forms 2
loading
Tags: GridControl
Jay Mooney
Asked On December 15, 2005 10:32 AM

Here''s my code: // Create Excel automation objects IWorkbook myWorkBook = ExcelUtils.CreateWorkbook(1); IWorksheet sheet = myWorkBook.Worksheets[0]; Syncfusion.GridExcelConverter.GridExcelConverterControl gecc = new Syncfusion.GridExcelConverter.GridExcelConverterControl(); gecc.GridToExcel(this.Model, sheet); // Save the workbook to disk so we can launch it via the file system myWorkBook.SaveAs(path); myWorkBook.Close(); ExcelUtils.ThrowNotSavedOnDestroy = false; if (openFile) { // Launch the saved workbook Process proc = new Process(); proc.StartInfo.FileName = path; proc.Start(); } Am I missing a setting?

stanleyj [Syncfusion]
Replied On December 16, 2005 01:10 AM

Hi Jay, A defect has been logged. Here is the link to the open issues.http://www.syncfusion.com/support/issues/xlsio/Default.aspx?ToDo=view&questId=1246 Regards, Stanley

stanleyj [Syncfusion]
Replied On February 21, 2006 03:42 AM

Hi Jay, Please try setting ConverterOptions. Syncfusion.GridExcelConverter.GridExcelConverterControl gecc = new Syncfusion.GridExcelConverter.GridExcelConverterControl(); gecc.GridToExcel(this.gridDataBoundGrid1.Model, "sheet.xls",Syncfusion.GridExcelConverter.ConverterOptions.ColumnHeaders|Syncfusion.GridExcelConverter.ConverterOptions.RowHeaders); Best regards, Stanley

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;