We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Non clickable grid question

Thread ID:

Created:

Updated:

Platform:

Replies:

38612 Dec 15,2005 03:16 PM UTC Dec 15,2005 05:17 PM UTC WinForms 6
loading
Tags: GridControl
Philip Bishop
Asked On December 15, 2005 03:16 PM UTC

I''m having a problem with a grid that I cant figure out. Somehow in a previous app of ours I made a grid non clickable but it was still scrollable with the scroll bars. I''ve been wanting to do that in a new app and I cant figure out what I did in the previous app to make this work. I''ve attached a sample that has 2 grids on one form. The top grid you can click each individual cell with the mouse. The lower grid(which was copied from the previous app i mentioned) you cant click any of the grid but the scroll bars. I cant seem to find the grid propery I''m missing thats allowing this to be non clickable. Any ideas? Thanks in advance. Phil

WindowsApplication115.zip

Philip Bishop
Replied On December 15, 2005 03:17 PM UTC

One other thing. We are still using 3110 of the grid if that makes any difference when you are testing. Thanks

stanleyj [Syncfusion]
Replied On December 15, 2005 03:44 PM UTC

Hi Philip, Try: this.GridControl1.TableStyle.Enabled = false; Best regards, Stanley

Administrator [Syncfusion]
Replied On December 15, 2005 03:47 PM UTC

I wasnt really looking for a solution really. I was more looking to see if you could tell me why the one grid in the sample i sent allowed clicking and the other did not.

Administrator [Syncfusion]
Replied On December 15, 2005 05:04 PM UTC

The reason you cannot click the grid are these two lines in the designer generated code. GridRangeStyle15.Range = Syncfusion.Windows.Forms.Grid.GridRangeInfo.Table ''... GridRangeStyle15.StyleInfo.Enabled = False This disables all cells in the grid.

Administrator [Syncfusion]
Replied On December 15, 2005 05:10 PM UTC

Ok then I guess we dont know how that got there. Maybe left over from another grid maybe? hmmmmmmmm

Administrator [Syncfusion]
Replied On December 15, 2005 05:17 PM UTC

I suspect at some point, someone clicked the topleft cell in the designer to select the whole grid, and then set the Enabled=false property in the cells property grid when the grid was not in Global Mode.

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

or the page will be automatically redirected to sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;