We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : Nov 16th 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Please Help!!! ChartWebControl is crashing the whole webpage repeatedly.

Thread ID:

Created:

Updated:

Platform:

Replies:

37735 Nov 29,2005 03:33 PM UTC Dec 1,2005 07:41 AM UTC WinForms 1
loading
Tags: Chart
Administrator [Syncfusion]
Asked On November 29, 2005 03:33 PM UTC

Hi, I m using a ChartWebControl in one of my ASPX page. The steps I am doing in that page is something like 1.In the "Page_Load" method of the webpage I m calling 2 methods a. InitializeChartAppearance() //Setting all the relavent appearence settings like axis range, color etc. b. InitializeChartSettings() //Setting the OutputFormat to DiskFile and imageURI path and the autotempfile cleanup property to true. 2. Next m calling a method Called "InitializeChartData()" which prepares series for the chart and adding it to the chart control. I am placing the chartweb control in a UserControl and the usercontrol m using. The user control also has a "Update" button which does a post back of the page. So on click of that button the chart data refreshes. Now when I run the application, I do some Back/Forward some couple of times and after that I click on the "update" button, the ChartControl is crashing showing the following messages 1. Error creating window handle. or, 2. Field not found (System.MissingFieldException). And once the error comes up, it comes repeatedly untill and unless I do a "iisreset" for the stratmenu-run. Can anyone help me getting rid of these crashes. I mean do I need to do something special to handle these isssues. Or do I need to dispose the chart control properly, if yes what would be the correct way of doing it? I crashes actually making the chartcontrol almost unusable, and resulting taking up a whole lot time, just to look into it. It may be possible that I m doing something wrong but can you please suggest me what I shall be doing in my code, so that the crashed do not happend at all. Please reply ASAP.

Administrator [Syncfusion]
Replied On December 1, 2005 07:41 AM UTC

Hi Bubu, I have followed the exact same procedure as said, in my project. But I am not able to reproduce the error. Please take a look at the sample attached. If the same problem occurs once again, please send your sample or modify the one i have sent. Also specify the version you have used for this. Kindly use the seperate WebForms Forum post to post your queries on any ASP.NET products. Thanks for your interest in Syncfusion products. Regards, F.Rashidha

F37735.zip

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;