We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : Nov 16th 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Excel - enter cell always shows formula

Thread ID:

Created:

Updated:

Platform:

Replies:

37416 Nov 21,2005 11:45 PM UTC Nov 22,2005 08:02 AM UTC WinForms 5
loading
Tags: GridControl
Adam K.
Asked On November 21, 2005 11:45 PM UTC

In the Formula Excel samples when you move the move into a cell, it always shows the formula. When i try this in Excel the top formula panel shows the formula but the cell shows the value. I have to double click in the cell or click in the formula bar for the formula to show up in the cell (as opposed to the value). Can syncfusion recreate this behavior ?? thks, ak

Administrator [Syncfusion]
Replied On November 22, 2005 12:10 AM UTC

Try setting these properties. this.gridControl1.ActivateCurrentCellBehavior = GridCellActivateAction.DblClickOnCell; GridFormulaCellRenderer.ForceEditWhenActivated = false;

Adam K.
Replied On November 22, 2005 12:26 AM UTC

where are these settings. do i need to add an additional reference. the compiler doesn''t find either of these GridCellActivateAction GridFormulaCellRenderer thks, ak >Try setting these properties. > >this.gridControl1.ActivateCurrentCellBehavior = GridCellActivateAction.DblClickOnCell; >GridFormulaCellRenderer.ForceEditWhenActivated = false; >

Adam K.
Replied On November 22, 2005 12:29 AM UTC

forget my stupidity .. somehow i lost the reference in my project. thks ak >where are these settings. do i need to add an additional reference. the compiler doesn''t find >either of these > >GridCellActivateAction >GridFormulaCellRenderer > >thks, >ak > >>Try setting these properties. >> >>this.gridControl1.ActivateCurrentCellBehavior = GridCellActivateAction.DblClickOnCell; >>GridFormulaCellRenderer.ForceEditWhenActivated = false; >>

Adam K.
Replied On November 22, 2005 01:10 AM UTC

I added these 2 lines into the GridDataboundgrid example . . it works in the sense that it doesn''t show the formula, but now i have a bigger problem . . . i can''t commit any cells . i hit enter and it stays in edit mode for the cell . . >forget my stupidity .. somehow i lost the reference in my project. > >thks >ak > >>where are these settings. do i need to add an additional reference. the compiler doesn''t find >>either of these >> >>GridCellActivateAction >>GridFormulaCellRenderer >> >>thks, >>ak >> >>>Try setting these properties. >>> >>>this.gridControl1.ActivateCurrentCellBehavior = GridCellActivateAction.DblClickOnCell; >>>GridFormulaCellRenderer.ForceEditWhenActivated = false; >>>

Administrator [Syncfusion]
Replied On November 22, 2005 08:02 AM UTC

You have to do additional, non-trivial, work to use formula cells in a GridDataBoundGrid. You must somehow maintain a collection of FormulaTag objects. Here is a KB link discussing this process. http://www.syncfusion.com/support/kb/grid/Default.aspx?ToDo=view&questId=104

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;