We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

XPTaskBarIItem Tag not set by constructor

Thread ID:

Created:

Updated:

Platform:

Replies:

37013 Nov 14,2005 05:19 PM Nov 16,2005 12:29 AM Windows Forms 1
loading
Tags: Tools
Bob Hogan
Asked On November 14, 2005 05:19 PM

I just upgraded from 3.0.1.0 to 3.3.0.0 and discovered the hard way that the constructor signature(s) for XPTaskBarItem changed. Or I should say they _didn''t_ change, but their semantics changed. Used to be there was a constructor whose last parameter was the Tag on the item (and BTW code was generated by the designer to call this constructor). Now that same parameter sets the ToolTip on the item instead of the Tag. Argh! That cost me a day. Not very nice guys. Maybe this will save someone else some time.

Mano J [Syncfusion]
Replied On November 16, 2005 12:29 AM

Hi Bob, Sorry for the inconvenience. I do see that same parameters used for tooltip in v.3.3.0.0. We have made the necessary changes to the XPTaskBar sample and set different parameters for tag and tooltip for our next release . Thanks, Mano

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;