We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Scrollbar behaviour of GDBGC

Thread ID:

Created:

Updated:

Platform:

Replies:

36484 Nov 1,2005 09:57 AM UTC Nov 1,2005 03:36 PM UTC Windows Forms 4
loading
Tags: GridControl
James Moore
Asked On November 1, 2005 09:57 AM UTC

Hi, I have a standard GC which uses a virtual datasource (all data provided through Query* events) which if I set VScrollBehaviour to Enabled the scroll bar is enabled/disabled when approproriate, however with the GDBG if I set the same property to enabled the Scroll bar does not enable/disable itself correctly but starts in an enabled state. (The GDBG has 0 rows, its just showing its headers). Am I missing some setting or is this the intended behaviour/a bug? Many thanks, James

James Moore
Replied On November 1, 2005 10:00 AM UTC

In fact after a little further testing the standard grid exhibits this behaviour too when row count is 0. It works correctly only when there are some rows..

Administrator [Syncfusion]
Replied On November 1, 2005 12:59 PM UTC

this.gridDataBoundGrid1.VScrollBehavior = GridScrollbarMode.Enabled; should make the scrollbar always be visible. If you want it to come and go depending upon the number of rows in the grid, then try either the Automatic or DetectIfShared setting.

James Moore
Replied On November 1, 2005 02:45 PM UTC

It should but if the RowCount is 0 initially then the scroll bar starts in the wrong state. (see the attached sample). James

WindowsApplication100.zip

Administrator [Syncfusion]
Replied On November 1, 2005 03:36 PM UTC

Your zip file did not contain a proj file so I could not run your sample directly. But I did copy the code in your Form an dpasted it into another project. When I run that project, the grid initially displays with a scrollbar and no data, and when I click the button, rows are added and the scrollbar is still there. This is the expected behavior as the VScrollBarBeavior is set to Enabled. I am running version 3.3. What version of our libraries are you using.

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;