We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

double click event, griddataboudgrid, hscrollbar

Thread ID:

Created:

Updated:

Platform:

Replies:

36016 Oct 18,2005 12:11 PM Oct 18,2005 03:57 PM Windows Forms 2
loading
Tags: GridControl
Giancarlo Aguilera
Asked On October 18, 2005 12:11 PM

For some reason the double click event of my grid control does not consistenly fire. If I scroll down and double click the third to last item in the grid, everything is OK, but if I then go back to the grid and double click the second to last row, the grid does not raise the double click event. Now, the grid I''m using is docked inside the top tab of a docking manager. Everytime an item in the grid is selected we have code that causes the dockmanager to auto hide the grid. So each time an item in the grid is selected, the grid''s tab goes into auto hide mode. Now again the problem is that more often than not the grid does not respond to the double click event. I was going crazy about the issue, so I used spy++ to track down who the heck was intercepting the message, and to my surprise the horizontal scrollbar of the grid is intercepting the mouse message. In response I disabled the horizontal scrollbar so that it would not show, and sure enough the problem went away. Now, however, I''m trying to figure out how to keep the hscrollbar but at the same time prevent it from intercepting the mouse messages. Am I making any sense here???? Thanks Giancarlo

Administrator [Syncfusion]
Replied On October 18, 2005 12:52 PM

>>So each time an item in the grid is selected, the grid''''s tab goes into auto hide mode If you comment out the code that makes the grid''s tab go into auto hide, does the double click work OK in this case? If so, you might wait until after a SystemInformation.DoubleClickTime time has passed before your turn on the auto hide. You could start a Timer where you now have the auto hide code. Then in teh tick event, turn off teh time and set the auto-hide mode. In your double click handler, you can just turn off the timer.

Administrator [Syncfusion]
Replied On October 18, 2005 03:57 PM

First and foremost, thanks for your response. I commented out the autohide code and sure enough the double click event fired as normal. However, I tried your suggestion but it did not seem to work. At least I know for sure that the autohide is doing something, what it''s doing I don''t know. Not sure what''s going on but I will continue troubleshooting. If you think of anything, please let me know. Right now I''m willing to try anything. Once again, many thanks Giancarlo >>>So each time an item in the grid is selected, the grid''''s tab goes into auto hide mode > >If you comment out the code that makes the grid''s tab go into auto hide, does the double click work OK in this case? If so, you might wait until after a SystemInformation.DoubleClickTime time has passed before your turn on the auto hide. You could start a Timer where you now have the auto hide code. Then in teh tick event, turn off teh time and set the auto-hide mode. In your double click handler, you can just turn off the timer.

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;