We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : Nov 16th 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

GridGroupingControl and Clickable cells

Thread ID:

Created:

Updated:

Platform:

Replies:

34869 Sep 19,2005 06:09 AM UTC Sep 20,2005 06:20 AM UTC WinForms 4
loading
Tags: GridControl
Administrator [Syncfusion]
Asked On September 19, 2005 06:09 AM UTC

Hi together, how can I set the "Clickable" property for all cells in my gridgroupingcontrol to false? Or is there an easier way to disable the cursor in my cell for the whole table (this is just for a "preview" grid where no cell is selectable).

Administrator [Syncfusion]
Replied On September 19, 2005 11:32 AM UTC

Hi You can make use of the following property to get the desired working. this.gridGroupingControl1.TableControl.Enabled = false; Regards Mouli.

Administrator [Syncfusion]
Replied On September 19, 2005 02:12 PM UTC

Hi Mouli, the problem with this solution is, that I am not able to scroll the grid, when I set the TableControl.Enable property to false - so do you know another way? Thanks in advance

Administrator [Syncfusion]
Replied On September 19, 2005 02:26 PM UTC

Hi You can make use of the currentcellactivating event and set the following property to set the cell not editable . e.Inner.colIndex = 0; Through this, you can select the entire row but you cannot edit the cell. Best regards Mouli.

Administrator [Syncfusion]
Replied On September 20, 2005 06:20 AM UTC

Thanks, but I think the best solution is the following: gridControl.Appearance.AnyRecordFieldCell.Enabled = false;

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;