We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Upgrade

Thread ID:

Created:

Updated:

Platform:

Replies:

27256 Apr 8,2005 10:32 AM UTC Apr 10,2005 07:31 AM UTC General Discussion 5
loading
Tags: General Discussion
Stefan Tsalapatis
Asked On April 8, 2005 10:32 AM UTC

Hi, After I installed the ver3.2 It continues to raise the same exception as of ver.3.0 through Debugger : A first chance exception of type ''System.IO.FileNotFoundException'' occurred in mscorlib.dll Additional information: File or assembly name Syncfusion.Tools.Windows, or one of its dependencies, was not found. I have clean all the previous installations Regards

Stefan Tsalapatis
Replied On April 8, 2005 10:49 AM UTC

Also In a control library with User Controls using the Syncfusion I can not see any more my controls in designer. It was compiled with 3.0

Stefan Tsalapatis
Replied On April 8, 2005 11:10 AM UTC

>Also >In a control library >with User Controls using the Syncfusion >I can not see any more my controls >in designer. >It was compiled with 3.0 > I must recreate all my user controls as new controls and then copy and paste the code in order to be able to work with them in design mode. Please send me an answer about these two problems ( Exceptions and User Controls )

David Whatley
Replied On April 9, 2005 05:30 PM UTC

I hope this isn''t how it is supposed to go... or upgrading would be out of the question. :/

Administrator [Syncfusion]
Replied On April 9, 2005 10:54 PM UTC

Hi Stefan, sorry for your trouble. Can you give more details how to reproduce this problem? Or best would be if you have a project that you can upload and we can debug into it. If you can''t upload a sample project I''ll have some questions: - Is this happening with all control or only specific controls? Which controls do you use? - When you open your control in the designer are there any messages shown in the Tasks pane? - Is the licx included? Does it reference Syncfusion.Core.LicensedComponent and do you reference Syncfusion.Core in your project? - Which framework version do you use? 1.1, 1.0 or 2.0? - Did you run AssemblyManager and if yes which settings did you use? Thanks, Stefan > > >>Also >>In a control library >>with User Controls using the Syncfusion >>I can not see any more my controls >>in designer. >>It was compiled with 3.0 >> > > >I must recreate all my user controls >as new controls and then copy and paste the code in order to be able >to work with them in design mode. > >Please send me an answer about these >two problems >( Exceptions and User Controls ) >

stefan_t
Replied On April 10, 2005 07:31 AM UTC

Hi Stefan Hoenig, 1. >- Is this happening with all control >or only specific controls? It is happening with the User Controls created with the previous version (3.0)New User Controls are displaying normally in design mode. These old controls use Syncfusion Controls or derived controls 2. >Does it reference >Syncfusion.Core.LicensedComponent and >do you reference Syncfusion.Core in >your project? ==== This is new !! ===== In ver 3.0 I referenced Syncfusion.Shared.Base Syncfusion.Shared Syncfusion.Tools.Base Syncfusion.Tools Syncfusion.Grid.Base Syncfusion.Grid. As you wrote I referenced the Syncfusion.Core and using Syncfusion.Core.Licensing === Yes ! == I am able to bring my old controls in Design Mode. I did not see anything about this in Release Notes. ( I hope it is my mistake ) 3. By the way, I have bought the Essential Source Suite 2 years now. I need the Source Code for my safety. == I don''t want to send to my customers assemblies which I don''t control. === From Ver.3.0 I must include the ===Syncfusion.Core which I can not find the Source Code in Your Distribution. ===== I knew (when I bought the Suite) that only the Designers - code was not in Source .This was understandable and I did not care because I had not reason to send to my customers such assembly. Now with the assembly Syncfusion.Core the things are changed ( For me is very serious ). I hope again to make mistake and somewhere to find this source code. 4. There is also the problem with the exceptions that I mentioned in the beginning of this thread. They had told me through Direct-Track they fixed it. 5. AS OLD CUSTOMER I BELIEVE == YOU DO VERY GOOD OBJECT ORIENTED PROGRAMMING === AND WE DEPEND ON YOU BECAUSE WE HAVE DONE A SERIOUS INVESTMENT BASED ON YOUR PRODUCT ( IT IS NOT THE MONEY BUT OUR WORK TO INTERGRATE AND EXTEND YOUR CONTROLS IN OUR PRODUCTION LINE ). SO, I BELIEVE THAT AT LEAST THE SIGNIFICANT GRID CONTROL AND SOME TOOLS MUST HAVE EXCELLENT QUALITY - EXTENSIONS - SMOOTH UPGRADING . Thanks Best Regards Stefan >- When you open your control in the designer are there any messages shown in the Tasks pane? >- Is the licx included? >- Which framework version do you use? 1.1, 1.0 or 2.0? >- Did you run AssemblyManager and if yes which settings did you use? > >Thanks, >Stefan > >> >> >>>Also >>>In a control library >>>with User Controls using the Syncfusion >>>I can not see any more my controls >>>in designer. >>>It was compiled with 3.0 >>> >> >> >>I must recreate all my user controls >>as new controls and then copy and paste the code in order to be able >>to work with them in design mode. >> >>Please send me an answer about these >>two problems >>( Exceptions and User Controls ) >>

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;