We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Menu bars

Thread ID:

Created:

Updated:

Platform:

Replies:

27250 Apr 8,2005 06:30 AM UTC Apr 8,2005 03:54 PM UTC Windows Forms 1
loading
Tags: Tools
Vinay
Asked On April 8, 2005 06:30 AM UTC

Hello, I''m currently using MainframBarManager in my MdiParent form and ChildFrameBarManager in the MdiChild forms. I''ve made enable customization false for both of them. Now the problem is When i move on from one form to another, the barItem of the previous form appears in the customization. Is there any way to disable the right click functionality. Also i''ve disabled the BarStyle (AllowQuickCustomization).

Administrator [Syncfusion]
Replied On April 8, 2005 03:54 PM UTC

Hi Vinay, If two MdiChildren merge into the same bar, their BarItems should both appear in the Customization Dialog regardless of which Child is currently active. This is expected behavior, as there are situations where the user will want to mix and match BarItems from several MdiChildren. If you want to disable customization, setting EnableCustomizing on the MainFrameBarManager should prevent all customization. If you don''t want one Child''s BarItems to appear in the customization Dialog for the other you can either merge the two Children into different bars, or dynamically update the Customizable property of the BarItem depending on which Child Form is active. Please let me know if you require any clarification on this or have any further questions on the topic. Regards, Gregory Austin Syncfusion Inc.

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;