We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

model.Translate on labels

I am using model.translate and when this is called any symbol that has a label retains its old position for click events but it is drawn in the translated position. I am using version 2.1.0.9. Also after model.Translate is called when I drag new symbols to the diagram they are being drop at the drop position plus the translated offsets. Is this the correct behavior? Thanks, Truman Lackey

2 Replies

AD Administrator Syncfusion Team February 8, 2005 10:38 AM

Hi Truman, I was able to reproduce both the issues that you have listed. This has been categorized as a very high priority bug and we will fix this as soon as possible. I am looking into the issue and will update this forum post when I learn more details about the problem. Regards, Prakash


AD Administrator Syncfusion Team February 10, 2005 10:40 AM

Truman, We have fixed the issues that you raised. These fixes will be made available as a part of the next update of Essential Diagram that is due by the end of the month. Applying a translation on the Model will no longer affect the symbol hit-testing or drawing. Symbols dragged from the diagram palette and nodes added using the interactive tools will also be correctly added at the location indicated on the View. An issue that still remains to be addressed is that following the Model translation, trying to resize a Shape or FilledShape node causes the node''s bounds property and selection handles to be drawn incorrectly. We are looking into this issue and will try to fix this as soon as possible. The problem related to page boundaries has been fixed as well, and boundaries will be drawn on the negative regions of the Model. Thank you for having brought these issues to our attention. Regards, Prakash

Loader.
Live Chat Icon For mobile
Up arrow icon