We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

Keyboard arrows not working

I have grid.AllowSelection set to Any and ListBoxSelectionMode set to MultiExtended, but the arrow keys are not working. I remember disabling them at some point a while ago but its escaping me at the moment how I did that. Any ideas on how to turn it on? Whatever I did to disable it was done with the grid''s properties, just not sure where/how.

3 Replies

AD Administrator Syncfusion Team December 14, 2004 09:06 AM

The main property that I can think of that would affect keyboard selections is AllowSelection. You might check to see if this is set more than once in case that is the problemm. Setting it to Any should allow moving using the arrow keys in the middle of the grid. At the end of a row, there is a WrapRow property that you would need to set to get the grid to wrap. If you have disabled cells (style.Enabled = false), this would prevent cells from becoimng current, and could affect arrow keys.


AD Administrator Syncfusion Team December 15, 2004 05:36 AM

Ok it turns out I was handling CurrentCellACtivating and setting e.Cancel to true. When I remove this the up and down keys work, however the cell that was clicked on my the mouse (when doing the initial row selection) is drawn with a clear center, i.e., without the row selection highlight like the rest of the cells in the row.


AD Administrator Syncfusion Team December 15, 2004 09:51 AM

Normally, setting e.ColIndex = 0 does not affect the arrow keys. Do you also have the row header cells disabled somehow? this.gridControl1.BaseStylesMap["Row Header"].StyleInfo.Enabled = false; The combination of these two setting will affect the arrow keys. If you enable the header cell, I think you will be able to use e.ColIndex = 0 in CurrentCellActivating without a problem.

Loader.
Live Chat Icon For mobile
Up arrow icon