We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

which had control of my cell type? Row or Col??

Thread ID:

Created:

Updated:

Platform:

Replies:

21840 Nov 24,2004 07:44 AM Nov 24,2004 12:26 PM Windows Forms 5
loading
Tags: GridControl
Philip Bishop
Asked On November 24, 2004 07:44 AM

Im trying to design a grid where the first row can have a max value of 100.00. I want every other row after that to have a max value of 99. So in the ide i set the col collection to max of 2 digits with no decimals for all cols. Then i went in to the row collection editor and on row one i changed it to be currency, system.single and said it can have 2 decimal digits and 3 digits to the left. Now when my sample loads I try to load 96.40 in the first cell in row one and all it shows me is 96. I can typ 3 digits in the cell but i cant type a decimla point or show the decimal or the 2 digits after. If you try and type in 2,1 u can only type 2 digits like i want it to. I cant figure how to make it so i can type 100.00 in all of row one and then make it how its working now of where i can only type a max of 99 in every other row after 1. Any ideas??? I tried attaching a sample but i keep getting the page cannot be displayed message. So i will try to attach a sample when i get back to work on monday

Administrator [Syncfusion]
Replied On November 24, 2004 08:19 AM

I think I did what you described (only did the first column, not all columns), and the row format seems to have precedence and cell 1,1 uses its format for me. Now I also set CellValueType (other wise the Format property does not apply). I also set some Validate properties to set the max values, but than that I think I did what you described. Below is the sample link for a project done with 2.1.0.9. In the sample, cell 1,1 accepts 95.6 and displays it as 95.60. Cell 2,1 displays 95.6 as 96. Cell 1,1 will accept 100 and cell 2,1 will not. If you want to always see two decimal places, you woul use somhing like #.00 as the format instead of #.##. http://64.78.18.34/Support/user/uploads/designer.zip

Philip Bishop
Replied On November 24, 2004 11:02 AM

Clay i left off i think that mine were currency cells. is there anyway i can email u a sample or some way i can get u my sample. the upload button isnt working inthr forum area so i cant attach a file like a normally do??

Administrator [Syncfusion]
Replied On November 24, 2004 11:14 AM

You can email your sample to support@syncfusion.com and reference this thread in the subject line.

Administrator [Syncfusion]
Replied On November 24, 2004 11:23 AM

I just emailed that to you. Thanks

Administrator [Syncfusion]
Replied On November 24, 2004 12:26 PM

I only had 2.1.0.9, so I had to convert the licx, and resx to 2.1.0.9. I could get it to work by opening up the row style, and changing CurrencyEdit.CurrencyDecimalDigits to 3, clicking off that property, and then setting the property back to 2. What this does is to explicitly set that property to 2 (you see it bold in the property grid). The unbold 2 that is initially shown there means that the row style should just use whatever is inherited from the tablestyle/columnstyle. If you want the rowstyle to actually impose its own number of decimal places, then you have to make sure the value is bold so the row style knows to use it, and just not inherit the value form other styles.

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;