We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

Upgrading from 2.0.5.1 -> 2.1.0.9 causes problem with the resx file

Hello, After upgrading to 2.1.0.9 I get "Invalid Resx File" error when I open the solution. I ran the ConvertResX.exe tool to migrate the resource file to the new version. When I load the solution again with the new resource file visual studio changes the size of the resource file down to only 34kb big while it originally was 704kb big meaning that I lost most of my resources. I''m attaching a zip file containing these resource files: SignalMatrix.resx.old is the original file which worked fine in 2.0.5.1 ,SignalMatrix.resx is the file after running ConvertResX.exe and SignalMatrix_after_open_the_solution.resx is the file after opening the solution. I hope that you can find out what is going wrong Best Regards Tommy Norman resource_files_6084.zip

3 Replies

AD Administrator Syncfusion Team October 5, 2004 12:00 PM

Hi Tommy, I think you are using VS.NET 2003 (1.1 Framework). Try using the utility named convertresx1.1.zip in this KB. This is compiled with 1.1 Framework. http://www.syncfusion.com/Support/article.aspx?id=10370 http://www.syncfusion.com/support/attachments/convertresx1.1.zip Before you re-compile your application, make sure that the .resx file''s build action is set to Embedded Resource. Best Regards, Jay N


TN Tommy Norman October 5, 2004 12:59 PM

Hi Jay, I have tried this but still the same problem occures. The compilation goes through okay with this converted resource file but when it''s done the resx file is back in this small 39 KB format again. I also got this error message during migration: See attachment Best regards Tommy Norman Convert_Syncfusion_resx_files_6282.zip


AD Administrator Syncfusion Team October 5, 2004 01:57 PM

Hi Tommy, Where does the ''ABB.PCM.Extension.PCMMenuextender'' and ''ABB.Tools.Common.ToolBase'' dlls located? The conversion utility will look for these dlls. Try placing them in the GAC or in the local folder while converting the resx file. Best Regards, Jay N

Loader.
Live Chat Icon For mobile
Up arrow icon