We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

RH Columns print on new page

When I preview or print my GridGroupingControl, the three right most columns are printing on a new page. This happens in portrait or landscape mode. In both cases after resetting the margins to .25 inch, there should be plenty of space to display the columns, most definitely on a landscape page. I''ve searched the KB and Forums but see no definitive answer and cannot see which property controls the column range (my apologies if I''ve missed it). The bitmap compression sample provided does not make sense here because there can be many pages of rows. Thank you Syncfusion support team. --Kenton

2 Replies

AD Administrator Syncfusion Team September 28, 2004 08:19 AM UTC

I tried to reproduce this problem in the attached sample, but it seemed to be working as expected for me using Can you see the problem in this sample? Are you doing something different? GCCPrint_8235.zip

KH Kenton Hensley September 28, 2004 10:07 AM UTC

Good Morning Clay and thanks for the response, First, should have mentioned that I''m using v. Second, I tested your sample app. and it works perfectly. I increased the width of column 3 till it pushed the columns onto a new page, then set the page to landscape and it all fit well. So what was different? 1) I noticed immediately I was using the the printer object to set the margins before showing the preview dialog: dlg.Document.PrinterSettings.DefaultPageSettings instead of: dlg.Document.DefaultPageSettings as in your exmaple. 2) Also, I had declared a class level PrintDocument variable. I was setting the margins in the QueryPageSettings event of the PrintDocument because obviously they were not working using the PrinterSettings object! And, there''s the rub: It appears the column break is not adjusted if you set the margins in the QueryPageSettigns event - in my case it was always breaking after column 6. However, it was setting Landscape correctly and presumably the margins (though it shows all as white space and I really can''t tell). A little oddity, indeed, but nothing to fret about since there is a solution: Solution: All goes well if I follow your sample and used the dlg.Document.DefaultPageSettings.Margins property. Thank you very much Clay.

Live Chat Icon For mobile
Up arrow icon