We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Hiding columns not working

Thread ID:

Created:

Updated:

Platform:

Replies:

19165 Sep 20,2004 01:46 PM UTC Sep 20,2004 03:35 PM UTC WinForms 2
loading
Tags: GridControl
Pete Davis
Asked On September 20, 2004 01:46 PM UTC

I have a grid control derived from the Syncfusion GridControl class. I''ve been working on this derived class for several months off and on. Anyway, one of the users (a developer) noticed that he''s not able to hide columns. The derived grid is a virtual grid that implements some custom data binding. I haven''t done anything specifically with hidden columns in the derived class, so I have no idea what I might have done that might keep the hidden columns from working. Hidden rows on the other hand are working fine. Any idea where I should even begin to look on this? Thanks. Pete

Administrator [Syncfusion]
Replied On September 20, 2004 02:06 PM UTC

Hi Pete, Did you override QueryColWidth? If yes, try setting e.Size = 0 and e.Handled = true if Model.HideCols[e.Index] is true. Otherwise I am not sure ... What are the other overrides you have? Do you have a small sample? Thanks, Stefan

Pete Davis
Replied On September 20, 2004 03:35 PM UTC

Yes, completely missed that. Thanks, that fixed it. >Hi Pete, > >Did you override QueryColWidth? > >If yes, try setting e.Size = 0 and e.Handled = true if Model.HideCols[e.Index] is true. > >Otherwise I am not sure ... > >What are the other overrides you have? Do you have a small sample? > >Thanks, >Stefan >

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

or the page will be automatically redirected to sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;