We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

DateTimePicker : the "/" character

Thread ID:

Created:

Updated:

Platform:

Replies:

18809 Sep 9,2004 10:23 AM Sep 13,2004 12:10 AM Windows Forms 2
loading
Tags: Tools
Lobrys
Asked On September 9, 2004 10:23 AM

Hi! I come back here, because I already have a problem with my datetimepickeradv control. DateTimePickerAdv CustomFormat : dd/MM/yyyy autoforwarding=true Our users have to seize dates in our applications. some people always use the "/", and some doesn''t.... So I would like to permit all kind of seize! in fact, if I enter "12/12/2004", I want 12/12/2004 if I enter "12122004", I want 12/12/2004 if I enter "1/2/2004", I want 12/12/2004 if I enter "01/02/2004", I want 12/12/2004 with the last line, when I tape "01" the cursor goes automaticly to the month field. Then I tape "/", it goes to the year field.... So, How to disable the "/" in that case? (if the "/" is the first character taped in the field, I think) Thanks for your support and of course, thanks for your product!!!! Bye lobrys

Administrator [Syncfusion]
Replied On September 12, 2004 11:12 PM

Hi Lobrys, Sorry for the delay in responding. Currently it is not possible to get all the four combinations that you have listed, but I will contact the development team to request for a few changes to be made to the DateTimePicker so that this combination could be achieved. I will update you on the status of this issue at the earliest. Thank you for your patience. Best regards, Stephen. >Hi! > >I come back here, because I already have a problem with my datetimepickeradv control. > >DateTimePickerAdv >CustomFormat : dd/MM/yyyy >autoforwarding=true > >Our users have to seize dates in our applications. >some people always use the "/", and some doesn''t.... >So I would like to permit all kind of seize! > >in fact, >if I enter "12/12/2004", I want 12/12/2004 >if I enter "12122004", I want 12/12/2004 >if I enter "1/2/2004", I want 12/12/2004 >if I enter "01/02/2004", I want 12/12/2004 > >with the last line, when I tape "01" the cursor goes automaticly to the month field. Then I tape "/", it goes to the year field.... > >So, How to disable the "/" in that case? >(if the "/" is the first character taped in the field, I think) > > >Thanks for your support >and of course, thanks for your product!!!! > >Bye >lobrys > > > > >

Lobrys
Replied On September 13, 2004 12:10 AM

Thanks! Just for info, and I am sure you have corrected that, my 4 lines of exemple were bugged! What I wanted to say was : >if I enter "12/12/2004", I want 12/12/2004 >if I enter "12122004", I want 12/12/2004 >if I enter "1/2/2004", I want 01/02/2004 >if I enter "01/02/2004", I want 01/02/2004 Thanks again! Bye lobrys

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;