We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

NotFoundError: Node.removeChild: The node to be removed is not a child of this node when updating datasource

I have an application that utilizes the Grid solution provided by Syncfusion, which generates the following error (image attached:


I have been unable to identify the steps to replicate the error, as it appears to occur randomly when updating the data displayed in the grid.

Searching in the forum I've figured out that this is a commom problem that have been solved in some other versions, but it is happening to me using the ej2 pack version 21.1.38, as seen in the package.json

I would apreciate some help.

4 Replies

HS Hemanthkumar S Syncfusion Team April 27, 2023 11:56 AM UTC

Hi Augusto Sigolo,

From your shared information we tried to reproduce your mentioned issue in the latest version (v 21.1.41) of the Syncfusion Grid by updating the dataSource using an external button but it was unsuccessful. For more information, please refer to the attached sample.

Sample Link: https://stackblitz.com/edit/react-dteqvi?file=index.js

If you are still experiencing the issue, we recommend attempting to reproduce it using the attached sample. If possible, please provide us with the following details to better understand the issue you are facing:

  1. Can you please provide us with a detailed description of the issue you are facing and what your expected scenario is?
  2. Kindly share your complete Grid rendering code with us.
  3. Share the video demo, Which help us to better understand your query.

We appreciate your cooperation in providing us with the requested information, as it will help us provide a more effective solution to your query.


Hemanth Kumar S

AS Augusto Sigolo April 27, 2023 05:26 PM UTC

Well, actually, the update is not made inside the component that renders the grid. It is made as follows:

I have this function that update the list that will be shown in the grid using setState:

After the list is updated, it is forwarded to the component that contains the grid by props:

 Changing the list results in the "reload" of the DeviceTable component that contains the GridComponent and its dataSource props is the array passed by the device prop of the DeviceTable component.

AS Augusto Sigolo April 27, 2023 07:02 PM UTC

After reading the stacktrace I found where the problem is in the template of one of the columns. I'm using this code to generate the template:

I'm using the following code to generate some buttons at the last column of the grid:


And this code generate this:

And is used as:

Using the react extensions, i figured out that the elements generated by the template are not nested into the cell, but in the GridComponent:

In my tests, removing the template made the error stop, can someone 

HS Hemanthkumar S Syncfusion Team May 2, 2023 12:56 PM UTC

Hi Augusto Sigolo,

We have attempted to reproduce the issue that you described by generating the Grid with a column template and passing the dataSource via props and changing the dataSource with the help of setState, but we were unsuccessful. Please refer to the attached sample for more details.

Sample Link: https://stackblitz.com/edit/react-p7xqun-6vgwpg?file=index.js,ChildComponent.js

If you are still experiencing the issue, we recommend attempting to reproduce it using the attached sample. If possible, please provide a sample of the grid that reproduces the issue. This will assist us in better understanding and validating your query.


Hemanth Kumar S

Live Chat Icon For mobile
Up arrow icon