We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

Grid and Button events not firing on Windows 11

I have a finished Winforms app with Syncfusion that works perfectly in Windows 10 and runs on Win 11, but has odd problems on Windows 11. I'm not convinced yet that this is a problem related to Syncfusion. In any case, button cells in the Grid control and also a button control on the UI seem to fail to trigger on clicks when running in production on Windows 11.  The Win 11 box is that of a client's, and I don't have access to her Windows 11 machine, so I can't track down this problem easily.  I have a feeling the problem is related to filesystem permissions. The app won't even throw exceptions and I can't seem to trap any errors for debug reporting. I am accessing app-specific files (SQLite and a few other files) in C:\ProgramData, setting all permissions and running as Administrator, and all the usual things along those lines. I'm asking to see if anyone else has these problems on Windows 11 Winforms apps. Thanks for any tips!

3 Replies

SJ Sathiyathanam Jeyakumar Syncfusion Team March 21, 2023 04:33 PM UTC

Robert Dickow,

We have reviewed the reported issue with the information provided. However, we regret to inform you that we were unable to reproduce the reported click event issue for button type cells in GridControl with a Windows 11 machine. We have attached the image for your references.

To assist us in further investigating the issue, we kindly request that you provide us with additional information.

  1. To better understand the problem, could you please provide a video demonstration along with reproducible code snippets or a sample?

  2. Have you tried to replicate the issue using the sample provided? If not, we recommend attempting to do so, as it may help to isolate the problem.



Attachment: CS_486c01a8.zip

RD Robert Dickow March 24, 2023 05:31 PM UTC

Thank you for your reply. I should have explained more clearly. My button implementations work perfectly as intended on my Windows 10 desktop. It runs perfectly and the grid buttons and other buttons work perfectly in Visual Studio and in the installed published project on my development machine. But when my customer runs the program on her new Windows 11 computer, the grid buttons do nothing. This has something to do with her environment, I am thinking, and not with Syncfusion. I am hoping someone else in the forum community may have clues to what Windows 11 might be doing that is causing this behavior. The exception traps and internal tracing files have not revealed any clues. The event handlers are never entered.

SJ Sathiyathanam Jeyakumar Syncfusion Team March 27, 2023 04:16 PM UTC

Robert Dickow

Thanks for the update.We have tried to reproduce the reported problem, but we are unable to reproduce the reported problem from our end. Can you please provide the more information related to your query?

Can you please share us below things?        
        1. Can you please provide the machine configuration of issue produced system?
        2. Can you please provide details or screenshot of Operating System used in issue produced system?
        3. Can you please provide details or screenshot of Microsoft Studio Visual Version used in issue produced system?
        4. Can you please provide your Syncfusion updated version?    

It will be helpful for us to check on it and provide you the solution at the earliest.

Live Chat Icon For mobile
Up arrow icon