We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

Hide date in scheduler


When viewing today (Thursday 02) we don't see the date in the scheduler, however when we move to tomorrow (see below) the date is displayed in the Scheduler.  How do we remove this?

3 Replies

SK Satheesh Kumar Balasubramanian Syncfusion Team March 3, 2023 11:53 AM UTC

Hi Alex,


You can prevent rendering of the date header row of the Schedule by providing only HeaderRowType.Hour in ScheduleHeaderRows as shown in the below code snippet. Refer to the below UG for more details.


UG: https://blazor.syncfusion.com/documentation/scheduler/header-rows

Demo: https://blazor.syncfusion.com/demos/scheduler/header-rows?theme=bootstrap4



<SfSchedule TValue="AppointmentData" Height="550px" @bind-SelectedDate="@CurrentDate">


        <ScheduleHeaderRow Option="HeaderRowType.Hour"></ScheduleHeaderRow>




Satheesh Kumar B

Attachment: ScheduleComponent_f4b7f0ee.zip

AL Alex March 3, 2023 01:19 PM UTC

Thanks will give that a try.

RV Ravikumar Venkatesan Syncfusion Team March 6, 2023 12:52 PM UTC


You are welcome. Try the shared solution and let us know if you need any further assistance on this.

Live Chat Icon For mobile
Up arrow icon