We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

How do I fix this Flutter dependencies error?

Hello there guys, I’m running into an error, when I try to build my flutter app using xcode, I’m trying to upgrade the ios version from 8 to 12, but I’m getting “the dependencies are outdated error” how do I fix this. I’m really new to flutter. Thanks in advance

5 Replies 1 reply marked as answer

NR Natrayan Ramalingam Syncfusion Team February 14, 2023 02:03 PM UTC

Hi Speednation,

Query 1: How do I fix this Flutter dependencies error?

We hope the following steps helps you to clear the dependencies outdated error.

  1. Open Terminal and navigate to the root directory of your Flutter project.

  2. Run the command "flutter pub upgrade" to update the dependencies of your project.

  3. After updating the dependencies, run the command "flutter pub get" to download and install the updated dependencies.

  4. Open your Flutter project in Xcode.

  5. Clean the project by selecting Product > Clean Build Folder from the Xcode menu.

  6. Rebuild the project by selecting Product > Build from the Xcode menu.

  7. If you encounter any errors, try resolving them by updating the version numbers of the packages in your pubspec.yaml file.

  8. Repeat the above steps until your project builds successfully in Xcode.

Note: while Xcode is not directly involved in the dependency update process, it is important to clean and rebuild the project in Xcode after updating the dependencies to ensure that the updated dependencies are used in the build process.

And also, we shared the flutter upgrading details below:




Marked as answer

SP speednation replied to Natrayan Ramalingam February 21, 2023 02:50 PM UTC

Thanks tried that and it worked but I,m now running into this now

I'm getting this error below warning in my Xcode 13.0

The iOS Simulator deployment
target 'IPHONEOS_DEPLOYMENT_TARGET' is set to 8.0, but the range of supported deployment target versions
is 9.0 to 15.0.99.

My deployment target is set @15.0

Any Ideas?

YG Yuvaraj Gajaraj Syncfusion Team February 22, 2023 02:10 PM UTC

Hi Speednation,

To resolve this, please delete the iOS folder in your project directory and then run the `flutter create .` command in the terminal, it will create an iOS folder with the latest configuration file, and the issue will be resolved.



SP speednation replied to Yuvaraj Gajaraj February 24, 2023 03:07 PM UTC

Thanks will definitely try it

YG Yuvaraj Gajaraj Syncfusion Team February 27, 2023 05:24 AM UTC

Most Welcome. Kindly get back to us if you have further queries. We are always happy to assist you.

Live Chat Icon For mobile
Up arrow icon