We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

No Header in serialized document

Hi, thanks for support.

I'm having problems in serialization of documents:

If i create a simple document like this and serialize it by using

const serialized = editorRef.current.documentEditor.serialize()

the headers are not gonna be serialized and the saved document will be something like 

this. (note no header)

I'm using NextJS 13:

"@syncfusion/ej2": "^20.3.61",
"@syncfusion/ej2-base": "^20.3.56",
"@syncfusion/ej2-react-base": "^20.3.56",
"@syncfusion/ej2-react-documenteditor": "^20.3.60",
"@syncfusion/ej2-react-dropdowns": "^20.3.60",
"@syncfusion/ej2-react-navigations": "^20.3.60",
"@syncfusion/ej2-react-pivotview": "^20.3.59",
"@syncfusion/ej2-react-richtexteditor": "^20.3.61",
"@syncfusion/ej2-react-spreadsheet": "^20.3.61",

next": "^13.1.6",
"next-compose-plugins": "^2.2.1",
"react": "^18.2.0",
"react-country-flag": "^3.0.2",
"react-dom": "^18.2.0",
"react-popper": "^2.3.0",
"react-redux": "^8.0.5",
"react-spinners-kit": "^1.9.1",
"react-to-print": "^2.14.11",
"react-world-flags": "^1.5.1",
"sharp": "^0.31.3",
"swagger-ui-react": "^4.15.5",
"typescript": "^4.9.5"

4 Replies 1 reply marked as answer

DS Dhanush Sekar Syncfusion Team February 12, 2023 04:34 PM UTC

Hi Filippo,

We apologize for the delay.

We have checked the reported issue. We couldn't reproduce the issue on our end. We have used the serialize API to get the SFDT string and opened the SFDT again. The header is present in the serialized SFDT string.

Stackblitz sample: https://stackblitz.com/edit/nextjs-3j26mj?file=pages%2Findex.js

Could you please modify the sample and send it back to us? so that we can reproduce the issue on our end and it will be helpful to validate this further.


Dhanush Sekar

FI Filippo replied to Dhanush Sekar April 21, 2023 08:12 AM UTC

Hi sorry for the delay. I ain't received the reply notification.

I fixed the problem by  downgrading and locking the syncfusion version

"@syncfusion/ej2": "~20.3.61",
"@syncfusion/ej2-base": "~20.3.56",
"@syncfusion/ej2-react-base": "~20.3.56",
"@syncfusion/ej2-react-documenteditor": "~20.3.60",
"@syncfusion/ej2-react-dropdowns": "~20.3.60",
"@syncfusion/ej2-react-navigations": "~20.3.60",
"@syncfusion/ej2-react-pivotview": "~20.3.59",
"@syncfusion/ej2-react-richtexteditor": "~20.3.61",
"@syncfusion/ej2-react-spreadsheet": "~20.3.61",

After this fix I ain't tried to update to a newer version.

Thanks and sorry again

Marked as answer

FI Filippo replied to Dhanush Sekar April 21, 2023 08:39 AM UTC

I tried right now with

"@syncfusion/ej2": "~21.1.41",
"@syncfusion/ej2-base": "~21.1.40",
"@syncfusion/ej2-react-base": "~21.1.41",
"@syncfusion/ej2-react-documenteditor": "~21.1.41",
"@syncfusion/ej2-react-dropdowns": "~21.1.41",
"@syncfusion/ej2-react-navigations": "~21.1.39",
"@syncfusion/ej2-react-pivotview": "~21.1.41",
"@syncfusion/ej2-react-richtexteditor": "~21.1.41",
"@syncfusion/ej2-react-spreadsheet": "~21.1.41",

and works perfectly.

SK Selvaprakash Karuppusamy Syncfusion Team April 21, 2023 02:40 PM UTC

Hi Filippo,

Thanks for your update. Please let us know if you have any other queries.


Selvaprakash K

Live Chat Icon For mobile
Up arrow icon