We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

Autocomplete and DopdownList using Virtualization do not page correctly. Skip is always 0 whileTake increments

I was monitoring the Entity Framework SQL produced by data access from some Blazor components and noticed the Skip value was always zero when using AutoComplete and DropDownList with Virtualization, while the Take value increased for each scroll action getting bigger and bigger. This is not the expected behavior for paging actions. On the other hand, the DataGrid performed exactly as expected. I have attached a test project which uses some of the standard Syncfusion examples to demonstrate this behavior. Watch the VS Output window for Skip/Take debug values.

Feedback will be appreciated and this will be an issue for large data sources.

Attachment: SyncfusionBlazorApp_Virualisation_Skip__Take_8ff7d421.zip

4 Replies

UD UdhayaKumar Duraisamy Syncfusion Team December 9, 2022 12:00 PM UTC

The “While virtual scroll in dropdown components 'top' parameter get incresed with more number of requests” already considered as a feature from our end, but we do not have any immediate plan to implement this feature. At the planning stage for every release cycle, we review all open features and implement the features based on feature rank, customer requested count and volume wish-list.

The status of implementation can be tracked through the below portal link: 


DA Dave December 9, 2022 02:20 PM UTC

Thanks for your prompt reply.

I have worked around this by implementing a simple list in the Adapter which gets filled with each skip/take database select. This is then returned to the control. Skip is set to the list.Count and Take is always 10. For auto complete the list is cleared if the filter value is changed. It works and is simple.

DA Dave December 10, 2022 12:45 PM UTC

UdhayaKumar, during testing I notice the 'Take' value incrementing by 5 after each scroll. You have already commented on this. On a rather more serious note, the value is not reset when the user types in the next suggest charterer. This would apply a new filter to the data source and return a new dataset. This should reset the 'Take' value to 5, but it continues to rise.

UD UdhayaKumar Duraisamy Syncfusion Team December 20, 2022 06:00 AM UTC

Hi Dave,

We request you provide additional details about the query as mentioned below. So that we could validate the query further and provide you with a prompt solution.

1. Exact requirement with a use case scenario.

2. Issue reproducing runnable sample.

3. Issue replication steps.

4. Video illustration of the issue.


Udhaya Kumar D

Live Chat Icon For mobile
Up arrow icon