We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

SF Maps not rendering - how do I debug?

Hi, I've got a Syncfusion maps component in my OSS application. It used to work fine earlier in the year but something has broken and I have no idea why. 

Here's the code: https://github.com/Webreaper/Damselfly/blob/develop/Damselfly.Web.Client/Shared/MapView.razor

When this renders, I end up with a 0x0 sfmaps element, with no content. I can't see any errors or indication as to why it's failing. Is there any verbose debugging I can enable, or can you spot anything that might indicate what's wrong?


3 Replies

IR Indumathi Ravi Syncfusion Team November 14, 2022 05:16 PM

Hi Mark,

When we tried to launch the provided application, we were unable to launch it. We are unsure which of the projects should be the starting project due to the large number of projects in the application. Also, we are experiencing an issue in launching the project, which can be seen in the screenshot below. 

However, we used the code available in the razor page "MapView.razor" and ran it separately in another application but were unable to replicate the issue with that code. Below is the video in which we tried to replicate the issue.

https://www.syncfusion.com/downloads/support/directtrac/general/ze/maps1455679998 

Please provide the replication steps in your project to replicate the reported issue. It will be helpful for us to analyze and assist you further.



MA Mark November 20, 2022 05:38 AM

Hi, thanks for the reply. 

This is a hosted blazor WASM app. To run it you need to set the startup project to Damselfly.Web.Server. The app takes a single command-line parameter - a folder that contains images which the app will index. 

To repro the problem, drop any image with GeoData into the folder specified on the command-line, and then when the app starts up, double-click on that image in the browser. You should then see the image with some details panes on the left-hand side, one of which is a 'Map view'. This should display a map, centred on the geolocation of the picture, but no map ever renders. See screenshot - I've indicated with the orange circle where the map should appear.


Any clues would be great


DamselflyScreenshot.jpg 




IR Indumathi Ravi Syncfusion Team November 22, 2022 02:54 PM

Hi Mark,


We have created a new ticket under your account for better follow-up in your queries. Please follow that ticket for further details.


Loader.
Live Chat Icon For mobile
Up arrow icon